Toad World® Forums

Background process counting tables hanging Toad Data Point


#1

A few times a day Toad hangs while a background process is “Counting Tables”. I did not ask it to this and do not know what triggers it. I wish it would only do this once when I first connect (SQL Server connection) and not do it again unless I want it to refresh. Is there any way to make Toad stop doing this automatically?

Thanks to any and all who can help me on this.


#2

Hi Greg,
I am afraid this cannot be simply disabled. But you can try to enable/disable caching (Options/Database/Cache).
May I ask you what version of SQL Server do you use? There must be some reason why the Toad hangs.

Regards

Petr


#3

It is a Sql Server 2008 database, I disabled the cache. Will let you know how it goes. It is a mirror database with a ton of tables in it.


#4

So far so good. No hanging while counting tables today (as there was no counting tables happening).

Thanks,


#5

When you take off caching it means we will be executing a lot more SQL. When counting the tables we are taking each table and caching the related info. It sounds like it might not be efficient with the large amount of objects.

if you are happy with turning off caching, then no worries. But caching is supposed to be helping the user experience. We would be willing to dig deeper if you wanted to open a support ticket.


#6

It definitely works better with the caching disabled when I am hitting a database with thousands of tables or views or stored procedures. I tried it again with the caching turned back on. I find it more annoying than it is worth, actually makes a noticeable difference in productivity, again only when hitting very large item databases.


#7

This should not be the case. Can you be more detailed on what exactly is better with caching disabled?
Every piece of information about an object needs to be queried from the database. Once we get that information once we cache it in memory and don’t query again. So once you have retrieved the info for an object is should be faster. If I have exact steps of issue I have have a Developer look into this.