Toad World® Forums

Beta 13.2.0.106, Schema Browser (DropDown style) ignores MouseUp event

It seems that the Mouse-Up event is ignored when clicking a table in the Schema Browser (DropDown Style). Even after releasing the left mouse button, the application behaves as if the button was still pressed.
Only a new click allows normal working again.

Screen

Hi Dirk. Thanks for animation, that really helps me see what's going on. I can't reproduce it though. For me, the only way I can reproduce this is if I actually hold the mouse down.

Anyone else?

Dirk, you only see weird behavior here, I guess?

So far I could only see the problem in the ListView in the Schema Browser. Are there other ListViews in Toad that I could check?

Not specific to Toad, but I occasionally still get the "stuck" shift key in Windows. (search the web for "windows shift key stuck") While this doesn't look like a shift key, perhaps some similar event? Or is it just this one place in Toad?

FWIW, I couldn't figure out how to duplicate this, either... :frowning:

Rich

Dirk and I were talking offline...He runs a Mac with Parallels, with a Windows 7 VM running as a guest, which is where Toad lives. Maybe this is related. If anyone else has a similar set up, please let me know.

1 Like

I could be wrong, but this sounds like “Ease of Access” sticky keys, designed for “disabled” typers. If you press shift five times consecutively you should get a popup explaining how to turn it on and how to disable it.

Hi,
I have the same effect if I click in the schema browser and then move the mouse up or down it's like above. I cross-checked it wit my 13.1 version and there is no such behaviour...

I run a normal PC with Windows 7 installed.

I made a change for Monday's beta, I think it will be back to normal.