Toad World® Forums

Beta Released (12.8.0.9)


#1

Beta Notes
Schema Browser
Incremental Search and Arrow-Key navigation (holding down the up/down arrow keys) will no longer cause RHS queries to execute until you let up the arrow keys or stop typing. This will make the LHS more responsive while you are looking for the desired object.

Resolved Issues
Issue
ID
Unsupported field type error during data compare using RAW columns as PK
118074


#2

I like the new feature of the schema browser but I suggest we should treat PgUp,PgDn like Up/Dn keys. The RHS query should execute only if we let up these keys.


#3

Good idea. I’ll add those too.


#4

John,

It seems the incremental search time setting is ignored during incremental search in SB LHS. I tried to search XML_IN table, but the focus jumps to the first table which start X, M and L. You have to type very-very quickly to the requested table at first.

I set my time setting to 2000 ms.

Other issue is I was unable to find v_$session view under SYS, because $ sign is not treated properly.

Would you kind check these issue? Thanks.


#5

I should write: You have to type very-very quickly to GET the requested table at first.


#6

Tree view or tabbed/drop down?


#7

Drop-down


#8

It’s working fine for me. Did you close and re-open the SB after changing the incremental search timer’s setting?


#9

I exit from Toad and now it’s working fine, but before that it was the third time SB ignored the complete string during incremental search and started to jump every letter one by one.

So I can reproduce the error but I don’t know what triggers the error.


#10

John,

I got it. If I go to Settings|Data grids|Visual|Styles and edit some property in Legacy (I changed the font size of Header to 10 from 9) SB incremental search is going to work in a crazy way. The SB was the current windows before setting’s change.

I don’t know you can reproduce the error.

My user setting is online via Dropbox, I can send you the link.


#11

For me, that just changed the setting it was supposed to. Please send me the link to your dropbox acct and I’ll try that.