Bug V17.0.163 : invalid object - selection, CPU 100%

I am connected with SYSTEM user.
I browse Invalid objects of a schema.
I want to select one (PL/SQL), the TOAD process is 50% CPU, and not responding.

As a diagnostic tool, do this:

  1. Go to help-> about.
  2. When the window opens, type in the word: freeze
    (there is no "place" to type it, just start typing)
  3. A "freeze detection" dialog will appear. Check the box and click ok.
  4. Go back to the schema browser and make the problem happen.
  5. At some point you will see this. Check where it says "click here".
  6. Then you'll see something like this:
  7. Check where it says "copy to clipboard" (please don't just CTRL+C yourself, you won't get everything).
  8. Click OK, come back to this thread and paste the result here.

That should tell me what's happening.


(After that, you can go back to help -> about and type "Freeze" again to disable freeze detection, or just restart Toad)

Diag. after freeze
TOAD_DEBUG_17Beta_freeze.log (68.2 KB)

Thank you for sending that.

The parser is taking a long time to parse your database package.

Can you send it to us?

My email is john.dorlon@quest.com


On a new DB Oracle 12c, I created one package Y8_MAP with error on schema TOAD.
When I choose Invalid Objects, I clic on package body, TOAD freezes. On pacage is OK.

I sent the PCK by mail.

Same on Package tab
on Spec : ok
on Body : freeze

Hi Mara,

Thank you for sending it. I tested it with your package.

For me, the package loads quickly, and the package body takes about 10 seconds. Does it finish loading for you if you wait?

I have a fast new laptop. If you have an older PC, maybe it will take up to a minute to load.

I will see if there is something we can do to make it load faster.


I tested it with Toad 16.2 and it was faster. In version 16.3, we added an option to display package references in the navigator. That seems to be what slowed things down. As of now, turning off the option doesn't improve speed because that only controls the display, not the actual parsing.

Starting in the next beta, you can right-click in the Editor navigator and uncheck "Show References" and that should help.

Perahps, you need to get the package reference only if the package is valid

No, the references are internal so it doesn't matter if the package is valid or not.

So, for example in the screen shot below - the variable g_post_tc_hook_exists is used at line 640, column 13. And I can click where I've indicated to jump down to that line.

Yes, the problem is on all package body, with the Schema Browser (package Valid or NOT).
I can see the code and references after 2 clics on popup message Freeze :
Annotation 2023-07-27 160720

In the next beta, these steps should make it faster:

  1. Right-click in the Editor's navigator and choose "Navigator Options"

  2. Then uncheck "Show References"

You can actually do these steps now but they won't help performance now. In Monday's beta, performance will be better if the "Show References" option is unchecked.

Yes, I'll try it