Toad World® Forums

Cancel data fetch not available


#1

When running a query, the hand icon(cancel data fetch) is not available(greyed).

What should I change in the parameters to have this functionality ?

Thanks in advance


#2

Morning Etienne,

When running a query, the hand icon(cancel data fetch) is
not available(greyed).

What should I change in the parameters to have this functionality ?

I suspect you ned to enable execution in threads, as follows:

View->Toad Options.
Oracle/Transactions (on the left).
Check “Execute queries in threads” on the right.

While you are there, make sure that “Commit after every statement” is
UNCHECKED. This is bad!

Cheers,
Norm. [TeamT]

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk


#3

Thanks Norm,

But queries in threads is checked so the problem is still there.

(Commit after every statement is unchecked)

Etienne

De : toad@yahoogroups.com [mailto:toad@yahoogroups.com] De la part de Dunbar,
Norman (Capgemini)
Envoyé : jeudi 28 octobre 2010 12:02
À : toad@yahoogroups.com
Objet : RE: [toad] Cancel data fetch not available

Morning Etienne,

When running a query, the hand icon(cancel data fetch) is
not available(greyed).

What should I change in the parameters to have this functionality ?

I suspect you ned to enable execution in threads, as follows:

View->Toad Options.
Oracle/Transactions (on the left).
Check “Execute queries in threads” on the right.

While you are there, make sure that “Commit after every statement” is
UNCHECKED. This is bad!

Cheers,
Norm. [TeamT]

Information in this message may be confidential and may be legally privileged.
If you have received this message by mistake, please notify the sender
immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still
check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under
the Freedom of Information Act, Data Protection Act or for litigation. Email
messages and attachments sent to or from any Environment Agency address may also
be accessed by someone other than the sender or recipient, for business
purposes.

If we have sent you information and you wish to use it please read our terms and
conditions which you can get by calling us on 08708 506 506. Find out more about
the Environment Agency at www.environment-agency.gov.uk


#4

How are you executing your query? The halt button should enable under the
following conditions…

  1. You have an active query executed via F9, Shift+F9, Ctrl+Enter, or pressing
    the execute button (green triangle)

  2. You are fetching all records into the grid by dragging the scroll bar of the
    grid to the bottom or pressing Ctrl+End in the grid

  3. You are debugging PL/SQL

  4. You are debugging a script using the script debugger

It does not activate when executing as a script (the lightning bolt button or
F5).

Michael


#5


#6

image001.png


#7

image002.png


#8

Sorry about that

The halt icon on the data grid is not available. The one on the toolbar is
working.

Thanks

De : toad@yahoogroups.com [mailto:toad@yahoogroups.com] De la part de Etienne
DELCOUR
Envoyé : jeudi 28 octobre 2010 15:47
À : toad@yahoogroups.com
Objet : RE: [toad] RE: Cancel data fetch not available

This one is working

This one is not working

De : toad@yahoogroups.com [mailto:toad@yahoogroups.com] De la part de Michael
Staszewski
Envoyé : jeudi 28 octobre 2010 15:30
À : toad@yahoogroups.com
Objet : [toad] RE: Cancel data fetch not available

How are you executing your query? The halt button should enable under the
following conditions…

  1. You have an active query executed via F9, Shift+F9, Ctrl+Enter, or pressing
    the execute button (green triangle)

  2. You are fetching all records into the grid by dragging the scroll bar of the
    grid to the bottom or pressing Ctrl+End in the grid

  3. You are debugging PL/SQL

  4. You are debugging a script using the script debugger

It does not activate when executing as a script (the lightning bolt button or
F5).

Michael
image001.png


#9

Sorry about that

The halt icon on the data grid is not available. The one on the toolbar is
working.

Thanks

De : toad@yahoogroups.com [mailto:toad@yahoogroups.com] De la part de Etienne
DELCOUR
Envoyé : jeudi 28 octobre 2010 15:47
À : toad@yahoogroups.com
Objet : RE: [toad] RE: Cancel data fetch not available

This one is working

This one is not working

De : toad@yahoogroups.com [mailto:toad@yahoogroups.com] De la part de Michael
Staszewski
Envoyé : jeudi 28 octobre 2010 15:30
À : toad@yahoogroups.com
Objet : [toad] RE: Cancel data fetch not available

How are you executing your query? The halt button should enable under the
following conditions…

  1. You have an active query executed via F9, Shift+F9, Ctrl+Enter, or pressing
    the execute button (green triangle)

  2. You are fetching all records into the grid by dragging the scroll bar of the
    grid to the bottom or pressing Ctrl+End in the grid

  3. You are debugging PL/SQL

  4. You are debugging a script using the script debugger

It does not activate when executing as a script (the lightning bolt button or
F5).

Michael
image002.png


#10

Sorry about that

The halt icon on the data grid is not available. The one on the toolbar is
working.

Thanks

De : toad@yahoogroups.com [mailto:toad@yahoogroups.com] De la part de Etienne
DELCOUR
Envoyé : jeudi 28 octobre 2010 15:47
À : toad@yahoogroups.com
Objet : RE: [toad] RE: Cancel data fetch not available

This one is working

This one is not working

De : toad@yahoogroups.com [mailto:toad@yahoogroups.com] De la part de Michael
Staszewski
Envoyé : jeudi 28 octobre 2010 15:30
À : toad@yahoogroups.com
Objet : [toad] RE: Cancel data fetch not available

How are you executing your query? The halt button should enable under the
following conditions…

  1. You have an active query executed via F9, Shift+F9, Ctrl+Enter, or pressing
    the execute button (green triangle)

  2. You are fetching all records into the grid by dragging the scroll bar of the
    grid to the bottom or pressing Ctrl+End in the grid

  3. You are debugging PL/SQL

  4. You are debugging a script using the script debugger

It does not activate when executing as a script (the lightning bolt button or
F5).

Michael