Toad World® Forums

Cancel data fetch on Described Table

I was unable to cancel the data fetch on a Described Table with ESC, using this shortcut has no effect. If I try to close the Desribe window it says “Data tab fetch in progress. Wait for it to finish or use the cancel button to cancel it”. Where is the cancel button?

It might be important that I used a VPN connection, and the table contains CLOB, BLOB columns. I pressed the Ctrl+End button accidentally and I tried to cancel the fetch, with no success. After a while I tried to close the connection from the toolbar then I got an “List index out of bounds (79).” AV.

I don’t know why ESC didn’t work for you. I just tried it and it worked for me.

The cancel button is just to the left of the navigator on the toolbar above the grid. It has a red circle with a slash through it, and a green triangle in the top left. It is disabled when a fetch or query execution is not in progress.

The cancel will happen after the current fetch is completed. When lobs are involved, fetches are one row at a time. So you may have to wait for the fetch of a clob to complete before the cancel can happen.

John,

It seems to be ok after I restarted Toad. Thanks.