Cannot create file ".....AppData\Roaming\Dell\Toad for Oracle\12.6\User Files\Toad.ini". Access is denied

After TOAD upgrade, I received this error message. Cannot create file "...AppData\Roaming\Dell\Toad for Oracle\12.6\User Files\Toad.ini". Access is denied. However I do have full access in this folder. Can someone please shed some lights here?

Which version of Toad are you running?
When do you get this error? As soon as Toad starts? When you try to shut Toad down?, etc.

Yes, I get this error as soon as Toad starts and try to connect session every time. I'm in TOAD version 12.6.0.53

You may be getting this error message because multiple copies of the same installation of Toad are running at the same time. If you think that might be happening, be sure to only run one copy of Toad at a time. If that is not the problem, then....

Instead of making a connection,
Go to Main Menu -> Utilities -> Copy User Settings
Choose "Create a clean set of user files", then OK
Toad will restart to a like-new state.

If you want to try to import your settings again, you can go back into that window, then choose "Copy user settings from a previous installation", and then find your prior version by clicking either the dropdown arrow or the ... button. It will be something like

c:\users\your-windows-user-name\AppData\Roaming\Quest Software\Toad for Oracle\12.5 (or whatever your prior version number was)

If the error comes back, then clear your settings again.
You can then copy just the minimum of user settings from the old version to the new.
To that that, you can copy these files from the 12.5 (or whatever your old version was)\User Files to 12.6\User Files folders

I recommend only the connections unless you really want to copy something else

  1. CONNECTIONS.* (all of your saved connections)
  2. SavedSQL.dat (SQL Recall)
  3. ToadActions.dat (Automation Designer apps and actions)
  4. Workspaces.dat (saved Workspaces)
  5. *.tpr (Project Manager projects)
  6. Databases subfolder under User Files (Schema Browser history and filters)

""Create a clean set of user files" works. Thanks so much for your help, John!

1 Like