Toad World® Forums

Toad error on startup

toad error while starting toad.

error is - Toad cannot update its client files. Make sure you have read and write permission to ......

Tried reinstalling and repairing TOAD - but still the same error ....any help greatly appreciated ...thanks

image

Did your workstation get refreshed? New Win OS or update? Are you logging in as a different user that has different file system privs? Had you installed Toad successfully on this workstation as that user? Any corporate security policy or firewall that could be the cause?

The message says exactly what's going on... based on the way you're logged into Windows, Toad cannot access some folders and files that it needs to run on your behalf. Not a Toad issue, but something on the file/OS system that's preventing you/Toad from accessing the files needed. Possibly the User Access Control (UAC) properties have changed for this user?

Can you read/write to your user's Appdata/Local folder and sub-directories?

Sorry for the delay. Based on the path in the "Details" section of the error message, I would say that something wacky has happened to your settings.

Here is what I suggest:

  1. If you want to preserve any settings (like connections), make a copy of the folder "c:\Users\n43870\AppData\Local\Quest Software\Toad for Oracle\13.1\User Files"
  2. Uninstall Toad (including any older versions, if any)
  3. Check "C:\Users\n43870\AppData\Local\Quest Software". If there are any Toad folders in there, besides what you just made a backup of, delete them.
  4. Check C:\Program Files and C:\Program Files (x86) to make sure that your Toad folders are gone from there too.
  5. Reboot
  6. Reinstall
  7. Start Toad.
  8. Close Toad
  9. if you want to get your connections back, copy the files Connections.* from the backed up User Files folder to the new one.