Toad World® Forums

Cannot drag in Schema Browser to higlight several columns

14.1.42.811 (same issue in 14.0 as well)

Raul

It seems like it would be nice to have. I'll see if it can be added. What version did that work in? I tried 13.3, 13.0, and 12.1.

The easiest way to do this now is:

  1. Click the first column that you want to select (anywhere in the row is fine...doesn't have to be gray area)
  2. Hold down Shift key
  3. Click the last column that you want to select (you shouldn't have to click each column...just the range)

Yeah, that shift key works.

I am not sure about where it worked.
I have 13.1.0.78 present somewhere. Looks like there is the same behavior.

Ok, I am not 100% sure, that this was present, but it sounds so very familiar action, and I was surprised it did not work. Perhaps I did press Shift for that earlier, but yeah, not totally sure about that.

Raul

The way it is now, after you multiselect columns, you can drag them into the editor (to add them to a query, for example).

I would have to disable this behavior to enable drag-select. If there is enough interest in this, it would probably have to be an option so users could choose which behavior they'd rather have.

I see there are other grids (for example SB-Tables-Indexes) in Toad which have drag-select enabled. Maybe that is what you were thinking of.

Yeah, I can see that this works for example SB-Indexes tab.

Raul