Toad World® Forums

Cannot launch Toad for Oracle has stopped working


#1

I use Toad for Oracle 12.8 everyday on window 7 64 bits, working fine. However, it has stopped all in a sudden. It does not tell any reason but just a box that says “toad for Oracle has stopped working - A problem caused the program to stop working correctly. Please close the program.”
I cannot find any log or info what the problem is. I tried uninstal, reinstall, reboot but just gives me the same error.

I installed a new version 12.10 toad for Oracle, it still gives the same error box telling to close the program.

Please help to shed some light as what The problem can be or what I can do to find out the issue. Desperate need to make this software work again. Thank you.


#2

You could try going to your user files (usually located in C:\Users{user}\AppData\Roaming\Quest Software\Toad for Oracle\12.10\User Files), and then edit Toad.ini file and add ‘Debug=1’ under Settings, Save, and try launching Toad. This will create a ‘ToadDebug.txt’ file. Post results here. Maybe there is something in there that could help diagnose the issue.

Then close Toad and remove the Debug=1 setting and save.


#3

Thank you Dennis. 12.10 installation did not create C:\Users{user}\AppData\Roaming\Quest Software\Toad for Oracle\12.10\User Files) dir for me. There is no Toad.ini file anywhere for 12.10, Is this correct ? could it be under different file name ?

Since I get the same error for 12.8 and 12.10, I try Debug=1 for 12.8, I got the same error box, Toad is never launched. I close the error box, but no toaddebug.txt could be found. Which path will it be under ?

Regards,
Grace


#4

Hmm ok, yeah - we were actually under Dell at the time of 12.8, so it would be under something like:

C:\Users{user}\AppData\Roaming\Dell\Toad for Oracle\12.8\User Files

but, the debug file (ToadDebug.txt) would be created in the same directory as the Toad.ini file, so if you changed it in there, then you have the right directory already.


#5

Does Debug=1 trace after toad launch? Since the error occurs and not able to start toad, is that why It did not generate toaddebug.txt?

I need this tool daily, really appreciate any light on how to make toad alive again. Thanks!

Regards,
Grace


#6

yeah, if it’s not even getting to the point of starting, then it wouldn’t produce that debug file. You could try running as administrator - R-click > Run as Administrator, but not sure if that’ll help or not.

When exactly did it stop working? Yesterday? Has anything changed in your environment by chance (eg Windows update)?


#7

Hello Grace,

As Dennis mentioned, you really need to locate your AppData folder to move forward. Generating that toaddebug.txt file may be able to tell us something, but more importantly, you could have a corrupt user file that is to blame for your issue. One thing I would recommend after finding your AppData direcotry is to rename all folders named after your Toad versions, for example, in this folder:

C:\Users{user}\AppData\Roaming\Dell\Toad for Oracle\

Rename ever sub-folder under “Toad for Oracle”, such as “12.8” and “12.10”. Then launch Toad and see if it starts up.


#8

It stopped 7 days ago. I tried run as administrator and with compatibility , but still same error.

I checked my pc, no window update for the last few months.

I installed 12.10 yesterday hoping that will start fresh but it still give the same error. I also suspect it is not even getting to the point of starting.

Any light how to find the culprit or make it working?

Regards,
Grace


#9

Not sure what you mean by rename sub folders. Do you mean rename 12.8 to 12.8tmp ? or rename 12.8/User Files to 12.8/User Filestmp ?

Regards,
Grace


#10

Brad,

I am so desperate and I tried both ways, still same error. Does this mean it’s not even getting to the pointing of looking for User Files ?

Appreciate your patience and help!

Regards,
Grace


#11

Is your default printer accessible? I have heard reports of inaccessible default printers causing problems (although not this severe).


#12

The first one, and do that for every folder in that directory


#13

Yes I read a thread in this forum before so have my default print set to PDF writer as recommended.

It seems the error occur before getting to the pointing of looking for User Files. What could be blocking it before that ?

Regards,
Grace


#14

I’m not sure if this has been mentioned yet, but there have also been reports of older Toad versions getting blocked by anti-virus software. Do you have anti-virus software and if so, would it be possible to disable it temporarily?


#15

Yes, we do have antivirus MCAfee on for years. Recently carbon black defense sensor is pushed to my laptop by my workplace. If this is the case, how can we get around it to tell cb confit that Toad is good to run ?

Regards,
Grace


#16

Ah there you go. You’d have to talk to your system admins for this - there’s probably a way to whitelist Toad somehow. Or maybe you can google how to do it.


#17

I just want to thank Dennis, Button, Brad and John and anyone else who have Input to help. It turns out to be an anti-virus software blocking toad to start up.


#18

Hello, guys! I get same error and is an incompatibility issue TOAD with service pack windows. I don’t know what to do! Will be another service pack that could fix this?
thanks!
Mónica