Toad for Oracle 16.2 will not open after reboot

I am on a windows 10 64 bit machine. I had to reboot my laptop because our VPN would not connect. After that was resolved, Toad won't open. I get no splash screen, nothing. I can see it in task manager, but that is all. It thinks that it is running, but nothing appears on my screen. No errors or anything else. I have rebooted my laptop, shut it down completely and restarted it. I have also uninstalled Toad and reinstalled it to no avail.

Kill Toad if it's still running and add DEBUG=1 to the [SETTINGS] section of Toad.ini. Search for DEBUG= first to be sure you do not include it twice. Its default location is %APPDATA%\Quest Software\Toad for Oracle\16.2\User Files\Toad.ini. Start Toad, give it 30 secs or so, and then kill it from Task Manager. See if a ToadDebug.log file was generated in %APPDATA%\Quest Software\Toad for Oracle\16.2\User Files\logs. If it was then please share it here.

I have done as you suggested, but it won't create a log file. There was no logs folder so I created one, but it just won't create a log file. I also tried it with 16.1 which also will not start and it too will not create a log file. I am considering uninstall ALL versions of toad that are on my laptop and removing all Quest Software data and folders and performing a clean install. What do you think?

Before uninstall/reinstall I'd try renaming %APPDATA%\Quest Software\Toad for Oracle\16.2 with Toad closed and trying again. If that doesn't work you can surely try uninstall/reinstall, but I don't have high hopes that it'll change anything. Were any Windows updates applied at your reboot? Does your company use any software that looks for malware that may have had its definitions updated?

There were no updates during the reboot or the cold startup, which I also did. As far as malware software, I will have to find out. I will do the rename of the 16.2 folder and let you know what happens.

If you have restricted internet access at your company, there are some steps you can try on this post.

I have checked and no definition updates for the malware. I did as you suggested and renamed the 16.2 folder while Toad was closed and even moved it to the TEMP folder. I then restarted TOAD to no avail. I assume that it was supposed to create a 16.2 folder again, but it did not and Toad remains in the background processes section of task manager and never comes to the Apps section like it normally does.

Thanks for your suggestion John, but we actually have unrestricted access to the internet in my company, however, I will try as you suggested, just in case that fixes it.

Hi John, that did not work for me. I think that I am going to totally uninstall all things Toad from my laptop, deleting everything that is related to Toad and reinstall the latest version to see what happens.

mstaszew, any other suggestions before I do a complete uninstall of all things toad and try to install it from the ground up? I really appreciate your help so far, but nothing has work as of yet.

I have no other suggestions at this time. The existence of Toad.exe in Task Manage and the fact that Toad did not produce any log files means it is locking up extremely early in the startup logic. I'll put a breakpoint in and see if I can narrow down what's occurring between app start and the first log message that is produced.

Thank you so much for your help. I will not do anything as far as uninstalling it at this time until I hear more from you.

We add a log comment on the first line of Toad's source. This would be what most would consider to the first line of the application although there is still some initialization code that gets executed before this. That initialization code is practically impossible to track down all of it and in what order it is executed. This code is usually quite small and used to initialize global objects or apply application wide settings that must be done immediately upon startup.

Given that Toad was working fine for you and then abruptly stopped after your reboot and that you have already uninstalled/reinstalled Toad once I don't think trying that again will change anything. This is feeling like an environment change on your PC, but I am unsure of what it is.

You could try the following...

  • Run Toad as administrator
  • Make sure there are no command line parameters being passed into Toad if you're launching from a shortcut. To rule this out, start command prompt and run Toad.exe that way w/o any arguments.
  • Scour Windows event viewer immediately after producing the issue and see if you can spot anything. I couldn't begin to suggest what you'd be looking for, but maybe something suspect will jump out.

Thanks Michael, I will try that and see what I can find.

Hi Micheal,

Well, I tried to do as you suggested, but Toad would not start from the command prompt at all. I started it directly from the file explorer by right clicking on Toad.exe and running as administrator. I then went to the windows event log, but nothing jumps out at me. Of course, like you, I am not sure what I am looking for either.

mstaszew, Well, here is what I did to resolve the situation. I uninstalled everything Quest/Toad related from my laptop and then removed any residual directories. I rebooted and then installed Toad version 14.2. When 14.2 came up, it prompted me to upgrade to 16.2. I chanced it and allowed it to upgrade and Toad 16.2 now works. Now I just have to put back all of my logins, but all is well. Thanks for your help today with this issue.

1 Like