Toad World® Forums

Toad 13.3 on Windows 10 won't start

This morning, my computer was sluggish and I clicked on the Toad icon several times before I realized that they were slowly starting. I went into task manager, killed them off and now Toad will not start.

I do not get a splash screen or anything, when I look at task manager, I see it sitting there not using any CPU but about 28 GB of memory.

Suggestions? I do not have admin rights on my laptop, so that limits what I can do

I suspect antivirus. Are you able to whitelist the Toad executable without admin rights? Failing that you might need to ask the admins to do it for you.

I think McAfee AV caused Toad startups to be incredibly slow in the past. But I might be remembering incorrectly.

HTH

Cheers,
Norm. [TeamT]

I use Toad almost every day, do you think it would suddenly start blocking? Let me see what I can do

Also, we use Symantec

I cannot find anything in Symantec logs and nothing is called out...

Morning Brett,

I use Toad almost every day, do you think it would suddenly start
blocking? Let me see what I can do

It is possible that an update to your AV system has reverted Toad back
to not whitelisted.

There might be another cause though. So:

Shutdown Toad.

Find toad.ini - for my 13.3 install on Widows 10, it's in c:\users\YOUR_NAME\AppData\Roaming\Quest Software\Toad for Oracle\13.3\User Files.

Edit the file and add DEBUG=1.

Restart Toad.

The file ToadDebug.txt should be investigated for any obvious problems,
and if necessary, posted here - check it for anything that might be
company confidential/personal/identifying of course.

Then repeat the above to turn debugging off (DEBUG=0 or just delete the
line.)

HTH

Cheers,
Norm.
HTH

As far as I can tell, the ToadDebug.txt file is not being created after adding DEBUG=1. Is it in the same directory as the toad.ini file? Searching the PC for the file did not find anything.

Toad definitely should not be gobbling up 28Gb of RAM before it even starts.

How about this?

  1. with Toad not running (not even in task manager), rename C:\Users\(your username) \AppData\Roaming\Quest Software\Toad for Oracle to C:\Users\(your username) \AppData\Roaming\Quest Software\BACKUP Toad for Oracle
  2. Try starting Toad again

This will restore Toad to a freshly installed state.
If that solves it, the problem must be in those files and I'll want to get a copy of them for debugging. Additionally, I can help you move back some of your settings.
If that does NOT solve it, then the problem is due to some change external to Toad.

Hi Brett,

it should be, yes. I can only assume that Toad isn't getting to the point of writing the file for some reason.

I see John has replied also, follow his instructions and ignore me for now! He knows what he's doing! :wink:

Cheers,
Norm. [TeamT]

I am now getting this error..

image

Thoughts?

Can you copy that file over from the backed up folder?

No, says I have to be an administrator to do it... I can't even create an empty file with the same name. Talking with our System Admin team to see if something changed.

1 Like

Worked with my system admins on this and they also can't figure it out at first glance. They even set Toad to run with Admin permissions..

Issue is resolved, Cyberark Endpoint Management had a rule that got activated recently. The rule is called "Block the stealing of creds using toad".. we disabled it and boom, started working again.

I suggest Toad work with Cyberark EPM to understand why they put in this rule.

I've never heard of them. I'll send an email. Thanks.

Hi John,

same issue here. Looks like corporate Carbon black Cloud sensor version 3.5.0.1627 or Zscaler blocking Toad startup.