Cannot Load OCI DLL for Toad 9.7.2

I have installed Toad for Oracle version 9.7.2 (32 bit) on my 64 bit laptop with windows10. Environment variables are set to Oracle Instantclient (32 bit). While connecting to the database I get the error "Cannot Load OCI DLL". oci.dll file is present but its not loading. My teammate uses same version of toad and oracle client can connect to database. Please help

Make sure that neither Toad nor Oracle are installed in a path with parenthesis.

So, not c:\Program Files (x86)....

Just uninstall and install somewhere like c:\Toad or whatever you want.

This is not a problem with newer versions of Oracle client and Toad. (I think the problem is in the Oracle client, but it's been so long, I'm not sure)

You know, John, I think it is still a requirement to use a path with no spaces. I have never successfully installed the Oracle client inside Program Files.


Good to know. I don't think I've ever tried to install the client into a path with spaces.

My clients paths are like:
c:\Oracle\Clients\Full(or instant)\x32(or x64)\version number\

My toad is installed in the C drive, outside program files(x86). Still same issue

Hm. I just tried and can't get Toad 9.7.2 to work with Oracle instant client version

However, I only tried it on Windows 10, which may be part of the problem. I know I have Toad 9.7 installed on some Windows XP virtual machines and it works just fine there. I can give you some more details on that tomorrow.

I can't get the instant client to work with ANY version of Toad on Windows 10, unless I run Toad as Administrator. Then it works.
I also installed the 11.1 instant client and 11.2 instant client on Windows 10. Toad 9.7 does not see them.
The and 11.2 instant clients work fine with Toad 10.1 on Windows 10