Toad World® Forums

Can't run GA FastReports with 12.10 beta installed?

Howdy!

With the new FastReports installed with 12.10 beta, my graphs have changed (colors and tick-style). I think I have everything fixed with my main graph, so I thought I’d check it against the settings in 12.9 GA. When I run my query and try to bring up the FastReport in 12.9 GA, I get an error popup:

The following error(s) have occured [sic]:
Cannot find class Datasets
Cannot find class Styles

I also get the same error with 12.8 GA. Thoughts?

Rich

You get this when you design a report in 12.10, and then try to import it into 12.8 or 12.9? Sorry to be Captain Obvious, but it looks like they aren’t backwards compatible. :frowning: You might be able to massage that XML data and get it imported in an older version, but I have no idea if that will work or not…

I put a message on their forum last month about your color problem, but it never got any responses. I’ll try again to get their attention.

Hey John,

Ahhhhh…

I had made the assumption that the FRs were stored in different UserFiles folders. I see now that they are stored with the query though. I forgot about that!

NBD here – it works great in 12.10 beta. But there are migration considerations for the FR reports that should probably be noted. So far I’ve come across the bar graph color and tick lines style (had to change it from “psDot” to “psSolid” to correct the look), and the overall graph size is smaller than in the older version.

Thanks, John!
Rich