Toad World® Forums

Change of keyboard shortcuts doesn't work in TOAD 14

Sometimes I am a beta user, but rarely. I don't want to update the stuff every two or three weeks...
So it seems I have to skip the whole version 14 and wait for 15 if there won't be a hotfix :cry:

It's logged and on the radar. Toad 14.0 is only a few days old now and we compile a list of issues in the beginning and discuss/prioritize defects as they become apparent. We allow for a little user adoption time with a new release to get a feel for the environment.

Hello Michael,

I'd just like to inform you that the issue still exists in TOAD 14.1.2.726 Beta.

Best regards,
Rainer

Similar to Rainer, I changed the following keybindings, which used to work in Ver 13:
Execute Statement from F9 to F5
Execute as Script from F5 to F9

F5 still runs Execute as Script, instead of what I selected (Execute Statement).
F9 still runs Execute Statement, instead of what I selected (Execute as Script).

I am on version: 14.0.75.662

Thanks!
Paul

Sorry to have to say that, but I am very disappointed about the new release 14.1.120.923. The issue with the not-working change of keyboard shortcuts still exits in this new version, so it is again absolutely worthless for me :frowning:
I can't understand how / why this could happen, and it seems I have to wait for a new version some months again :frowning:

It's fixed in 14.2 beta. You can get that now. Here.

Sorry John, it is not fixed in 14.2 beta. The issue still exists, I checked this right now.

Furthermore I wonder how this can happen. I reported the bug months ago and Michael wrote that it is on the radar and will be fixed in one of the next betas. This was related to 14.1 beta, and now we are at 14.2 beta... :cry:

I did put a change in to keep Editor shortcuts up to date with changes made in options.
However, I see that this specific example, SQL Recall, was excluded. I am fixing it now.

It's also Execute, that means, I want to change F8 and F9

You'll be able to switch them next beta, which should be on Monday

Yep, changing keyboard shortcuts works again in the latest beta :+1:t2: Thanks!!! :smiley:

You're welcome. FYI, I accidentally caused these two problems with the recent shortcut changes, but they will be fixed next beta.

Now there's the next little issue with the keyboard shortcuts in the latest beta. Changing for example F8 and f9 works, but with the next restart of TOAD, the default shortcuts are restored.

Additinioal information: In the settings it looks like F8 and F9 are still changed after restart, but the behavior is like default.

I just did this:

  1. Start Toad, open Options, set Execute Statement as F8 and SQL Recall as F9.
  2. Open Editor, enter a SELECT and hit F8 - statement runs. Hit F9, SQL Recall opens.
  3. Close Toad
  4. Start Toad
  5. Open Editor, enter a SELECT and hit F8 - statement runs. Hit F9, SQL Recall opens.
  6. Close Toad
  7. Start Toad
  8. Go to Options, Execute Statement is still F8 and SQL Recall is still F9.

It seems ok to me. If something isn't working for you, can you give me some clear steps to reproduce it?

I just did the same as you, and everything is fine. Seems that the misbehavior just happens sometimes, but not always. I have no clear steps to reproduce, but when I should find them, I will let you know.

Best regards,
-Rainer

Now I have an additional information. Yesterday evening I closed TOAD and restarted my PC. Now today, the behavior of F8 and F9 is default (F8 = SQL Recall and F9 = Execute), although in the shortcut configuration it is like I set it (just the other way round). Workaround: Delete both shortcuts an set them again like I want them to be.

Still I have no idea what triggers the behavior to default again...

Best regards,
-Rainer

I wonder if it has to do with how the editor is opened....like if you open the editor before a connection is made, if it is opened by opening a workspace, etc.

When I start TOAD, one connection is opened because it is marked as Auto Connect in the DB login window. In the window settings the editor and the schema browser are marked as Auto Open with the schema browser as auto-open bring to front. This means that always when my TOAD is just started, an editor and a schema browser window with my default connection are opened and the schema browser is the active window.

Rainer, does his happen often - when you restart Toad and the shortcuts are wrong? I haven't been able to reproduce it.