Toad World® Forums

Compile using F9 causes AV

Reloading a file (this is a package body) in the Editor and make a compile using F9 shortcut generates an AV if F9 keystroke happens under the reload process.

I tried:

  1. Open package body file into editor
  2. Click the "reload file" button
  3. Press F9 key

But there was no error when I did that. What should I do differently?

I sent the Eurekalog offline.

Thank you. I have seen that one in our anonymous error logs but have never been able to reproduce it. Is your file read-only?

No, I loaded a Workspace with 10-15 files and have been working for a long time on this project. All open files are saved to disk and belong to an SVN repo chekout.

Every package statement and body files contains an svn keywords part, and after Commit operation Toad always ask to reload the content of the active tab. (Editor|Open/Save|Prompt for reload on activation... is checked). But I was able to reproduce the AV with manual reload of the file and using the F9 shortcut.

Tamas, that call stack you sent shows that the active tab is changing in the editor. Are you manually changing tabs at some point, or does that happen automatically when you are doing one the of the steps above?

well..... i don't remember exactly.

I try to reproduce the AV, because yesterday it happens more than once, but today I was unable to reproduce the same error.

OK, I see what's happening here. We'll have it fixed in 14.2.

If you go to Options -> Editor -> Open/Save, and turn off the "prompt for reload on activation if timestamp has changed" option, I think that will prevent this error.

Or, if you leave that option checked, but just tell it "No", when it prompts for reload, and then click the "Reload" button manually as needed. I think things will be OK if you do that.