Toad World® Forums

Critical Error - Failed to open settings.

I’m getting the following popup error which needs to be clicked through for many, if not all, scripts that I run. I run over 60 scripts daily.


Failed to open settings

Failed to open settings for module DBMSOutput due to error Attempting to Deserialize an empty string. Reverting to defaults.


I need to get this error fixed asap. Anyone have suggestions?

Try making a copy of the settings.xml file in the following Win7 directory:

C:\Users<user>\AppData\Roaming\Quest Software\Toad Data Point

C:\Users<user>\AppData\Roaming\Dell\Toad Data Point

Then delete the original and relaunch TDP. It should create new settings.xml file and might fix the issue. If it doesn’t work you can always revert back to the settings copy.

poll.pngDid renaming your settings.xml help? It is a good idea. The DBMS error can also be avoided by turning off polling for DBMS output lines. To turn off follow these steps:

  1. Connect to Oracle

  2. Execute something in the SQL Editor

  3. Go to the Messages tab.

  4. Press the Poll for DBMS lines. This tool button is a sticky button so set it so Polling is turned off.