Toad World® Forums

Disabled (read-only) files in Editor


#1

Hi,

TOAD ver 10.6.0.42.

When I open a file in Editor, I can see its status as “Uncontrolled”.
As soon as I type or copy "CREATE OR REPLACE PROCEDURE " OR “Load in Editor” the existing procedure code OR compiling, the file status changes to “Disabled” and it becomes read-only. I found the only way to continue - drop procedure :).

Is there some TOAD option which is responsible for this behavior?

Thanks,
Andrew


#2

I have a guy on my team where that happens as well. After compiling a proc, the editor tab switches to read only. We have team coding enabled in this dev database however haven’t ever really figured out how best to utilize it - wondering if that has something to do with the editor flipping to read only.

Anyone have any ideas?


#3

[ Attachment(s) from John Bowman included below]

Hi Troy,

It’s quite possible this is the cause of your issue. If the procedure
you’re compiling is controlled by a Code Control Group, or the Team Coding
setup is tied to a version control provider with the “Automatic
Check-in” option turned on, it may be locking the code after it has been
checked-in.

There are a couple of things you can check to help solve this. First, check your
Team Coding status window by clicking on the button on the Team Coding toolbar
or selecting Utilities à Team Coding à Team Coding Status. The status window
will look like this:

This will tell you if Team Coding is installed in the database and whether a VCS
Provider is enabled and connected. It will also show your permissions as to what
Team Coding settings you’re able to change on the bottom.

Next, check the Source Control page of your Toad Options window, through View à
Toad Options à Source Control. Check to see if “Automatic Check-In”
is selected. If it is, you can de-select it. You’ll need to manually check
the procedure in after you compile it, but it may keep the issue you’re
experiencing from happening:

Finally, see if this procedure is defined within one, or more Code Control
Groups, by clicking on the Code Control Groups button on the Team Coding
toolbar, or selecting Utilities à Team Coding à Code Control Groups:

If the procedure is defined in more than one Code Control Group, you may want to
adjust your group definitions so that it belongs to only one group. Otherwise,
you may confuse Team Coding, as it won’t know which VCS project to attach
this procedure to.

If you have some confusion as to how to utilize Team Coding within Toad, I would
suggest the following resources:

Attachment(s) from John Bowman

1 of 1 File(s)

Subversion Integration with TOAD.doc
image006.jpeg


#4

[ Attachment(s) from John Bowman included below]

Hi Troy,

It’s quite possible this is the cause of your issue. If the procedure
you’re compiling is controlled by a Code Control Group, or the Team Coding
setup is tied to a version control provider with the “Automatic
Check-in” option turned on, it may be locking the code after it has been
checked-in.

There are a couple of things you can check to help solve this. First, check your
Team Coding status window by clicking on the button on the Team Coding toolbar
or selecting Utilities à Team Coding à Team Coding Status. The status window
will look like this:

This will tell you if Team Coding is installed in the database and whether a VCS
Provider is enabled and connected. It will also show your permissions as to what
Team Coding settings you’re able to change on the bottom.

Next, check the Source Control page of your Toad Options window, through View à
Toad Options à Source Control. Check to see if “Automatic Check-In”
is selected. If it is, you can de-select it. You’ll need to manually check
the procedure in after you compile it, but it may keep the issue you’re
experiencing from happening:

Finally, see if this procedure is defined within one, or more Code Control
Groups, by clicking on the Code Control Groups button on the Team Coding
toolbar, or selecting Utilities à Team Coding à Code Control Groups:

If the procedure is defined in more than one Code Control Group, you may want to
adjust your group definitions so that it belongs to only one group. Otherwise,
you may confuse Team Coding, as it won’t know which VCS project to attach
this procedure to.

If you have some confusion as to how to utilize Team Coding within Toad, I would
suggest the following resources:

Attachment(s) from John Bowman

1 of 1 File(s)

Subversion Integration with TOAD.doc
image005.jpeg


#5

[ Attachment(s) from John Bowman included below]

Hi Troy,

It’s quite possible this is the cause of your issue. If the procedure
you’re compiling is controlled by a Code Control Group, or the Team Coding
setup is tied to a version control provider with the “Automatic
Check-in” option turned on, it may be locking the code after it has been
checked-in.

There are a couple of things you can check to help solve this. First, check your
Team Coding status window by clicking on the button on the Team Coding toolbar
or selecting Utilities à Team Coding à Team Coding Status. The status window
will look like this:

This will tell you if Team Coding is installed in the database and whether a VCS
Provider is enabled and connected. It will also show your permissions as to what
Team Coding settings you’re able to change on the bottom.

Next, check the Source Control page of your Toad Options window, through View à
Toad Options à Source Control. Check to see if “Automatic Check-In”
is selected. If it is, you can de-select it. You’ll need to manually check
the procedure in after you compile it, but it may keep the issue you’re
experiencing from happening:

Finally, see if this procedure is defined within one, or more Code Control
Groups, by clicking on the Code Control Groups button on the Team Coding
toolbar, or selecting Utilities à Team Coding à Code Control Groups:

If the procedure is defined in more than one Code Control Group, you may want to
adjust your group definitions so that it belongs to only one group. Otherwise,
you may confuse Team Coding, as it won’t know which VCS project to attach
this procedure to.

If you have some confusion as to how to utilize Team Coding within Toad, I would
suggest the following resources:

Attachment(s) from John Bowman

1 of 1 File(s)

Subversion Integration with TOAD.doc
image004.jpeg


#6

Weird!! Sorry Andrew, your original post never got to my inbox, so I thought
Troy initiated this issue.

Andrew, some of the information included below may apply to you when loading
objects into the editor from the database. If, however, you’re loading a
script file off your hard drive, it’s possible the editor is noticing this
file is marked as read-only on the hard drive and making it read-only from that.
Or, you may have a Code Control Group that manages script files in that
directory, as shown in one of the pictures in the below e-mail. This might also
cause that behavior for your environment.

Can you give an example of where this is happening??

-John
image005.jpeg


#7

Weird!! Sorry Andrew, your original post never got to my inbox, so I thought
Troy initiated this issue.

Andrew, some of the information included below may apply to you when loading
objects into the editor from the database. If, however, you’re loading a
script file off your hard drive, it’s possible the editor is noticing this
file is marked as read-only on the hard drive and making it read-only from that.
Or, you may have a Code Control Group that manages script files in that
directory, as shown in one of the pictures in the below e-mail. This might also
cause that behavior for your environment.

Can you give an example of where this is happening??

-John
image004.jpeg


#8

Weird!! Sorry Andrew, your original post never got to my inbox, so I thought
Troy initiated this issue.

Andrew, some of the information included below may apply to you when loading
objects into the editor from the database. If, however, you’re loading a
script file off your hard drive, it’s possible the editor is noticing this
file is marked as read-only on the hard drive and making it read-only from that.
Or, you may have a Code Control Group that manages script files in that
directory, as shown in one of the pictures in the below e-mail. This might also
cause that behavior for your environment.

Can you give an example of where this is happening??

-John
image006.jpeg


#9

Thank you John!
It is VSS issue for sure. Most likely Groups…
I’m currently working with Quest support team and our DB/VSS admins.
I’ll let you know.

Andrew


#10

We had old SQL Navigator Team Coding Objects installed on the server.
TOAD used them and looks like it caused the problems.
Our DB admin reinstalled them. TOAD works now.

Thanks,
Andrew