Toad World® Forums

Displaying schema browser and editor on separate tabs?

I just installed 11.6 on my new laptop at work. When I open a schema browser, it covers my editor tabs. I can go to Window and select the editor or browser, but what I’d really like is to have the browser and editors all appear as tabs on the same window (if that’s the right term). This is the way it worked on my old laptop, which had 11.2. I’m sure the functionality is still available in 11.6. I just don’t know how to access it.

I think you mean tile your windows.

1513.pic.jpeg

I use 12.5 and it has same window/tabs features as 11.6. Below one configuration I use - two editors, schema browser and forum - all as tabs:

Many other configuration options are also available many other toolbars can be selected (only standard and window bar selected on this picture)

Your picture didn’t come thru. Please repost.

If I understand you correctly this has never been possible. Toad is an MDI application and can’t be used in the way you ask for.

On 07/25/2014 08:44 AM, bkelso wrote:

Displaying schema browser and editor on separate tabs?

Thread created by bkelso
I just installed 11.6 on my new laptop at work. When I open a schema browser, it covers my editor tabs. I can go to Window and select the editor or browser, but what I’d really like is to have the browser and editors all appear as tabs on the same window
(if that’s the right term). This is the way it worked on my old laptop, which had 11.2. I’m sure the functionality is still available in 11.6. I just don’t know how to access it.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

It’s not tabs, but try this: From the main menu, Window -> Tile Vertical

I know this is a very old post, but I didn’t see a real solution to the question, and this has just become a problem for me - and in the middle of a TOAD session. I’m using 12.7.1.11, and have always been able to have multiple editor tabs and multiple browser tabs on the same window - as well as having multiple connections on separate tabs, each with its own editor and browser tabs - so to switch between connections, editor sessions and schema browsers, I had only to click a tab.

Today, in the middle of a TOAD session, I opened a new connection, and when I opened the schema browser, it took up the whole page, covering not only the new session’s editor window, but the other session as well. Yes, I can tile the windows, and if all I’m doing is an editor session and a schema browser in a single database, that’s okay. But I’m often comparing objects or code between development, test and production - and this makes it really difficult.

when I opened the schema browser, it took up the whole page

Maybe the previously active window was maximized. Since Toad is an MDI application if the active child window is maximized, newly opened child windows are also maximized. If the active window is in a normal state (i.e. not maximized, not minimized) then newly opened child windows are also in a normal state.

Was the new Schema Browser fully maximized or just very large blocking the other windows? It sounds like splitting hairs, I know, but it’s an important distinction. If it was maximized did you maximize another window prior to opening the Schema Browser?

If none of that sounds like the problem then there might be a bug here to investigate. Reproducible steps would help.

I’m often comparing objects or code between development, test and production - and this makes it really difficult.

I don’t know if this would help, but would it help having additional Window|Tile features that act on windows of the active session only. I wasn’t able to get it to work in a quick test, but the code for tiling is quite simple so with more time it should be a no brainer.

As a workaround if you’re working in only a handful of connections you could open a Toad instance for each. This way Tile will allow for side by side Editor/Schema Browser for one connection only.

Michael

Thanks for your response, Michael.

Maybe the previously active window was maximized.

The previously active window was maximized within the limits of the Toad window - if that makes sense - and that has always been the norm for me. I’ve never used the Maximize button because there’s never been any need to. Every window was accessible via a tab. Wish I could provide reproducible steps, but I can’t seem to get back to the previous behavior.

I do think Window|Tile being active on only the current session would be a help. When it works on all open sessions you have a cluttered screen filled with very small windows.

For now I’ll try multiple Toad sessions and limit my number of connections.

Thank you again.

Ok, I will look at adding the tile by session. I have worked out the kinks and it works well.

The previously active window was maximized within the limits of the Toad window - if that makes sense

Based on this and the description of the issue it sounds like the window was maximized. Not that Toad had to be maximized, but its active MDI child window was maximized within the limits of Toad. That will cause newly opened Schema Browser to open to the same size.

Every window was accessible via a tab.

I believe you are referring to the tool buttons. Toad does not use a tabbed interface. It is an MDI application surfacing buttons for activating various windows and sessions. This was part of my confusion because other apps (SQL Developer) do use SDI interface with tabs. Toad does not.

Michael

So maybe it’s Toolbar settings, then. Possibly I accidentally deactivated some tool buttons without realizing it. I’ll explore that possibility.

Thanks again!

For the record, a co-worker suggested ‘Restore Defaults’ on the Toolbar context menu, and that rleturned my interface to the way it used to be: one toolbar showing buttons for connections, and a toolbar beneath that one with buttons for editor and schema browser sessions for those connections.

I do appreciate the clarification on the tabs vs. toolbar buttons. Makes more sense now.

Ruth

This is a window issue . Right click on the right of any editor tab the enable the window bar . Issue will be resolved.