Toad World® Forums

Displaying small numbers in sci notation


#1

Howdy,

In .45, I have the “Display large numbers in Scientific Notation” unchecked in Prefs->Data Grids->Data. Could this also apply to small numbers? The magic number for the cutoff on the right of the decimal seems to be 1E-5.

Thoughts?

TIA!
Rich


#2

Hm, well, it’s supposed to…and for me it does…

SciNot.jpeg

It’s early - is there still too much blood in your caffeine stream? :slight_smile:


#3

Oooooh, the caffeine’s kicking in now! Turns out I just needed to close/reopen Mr. Editor after changing the option and all’s well.

Thanks, John!

Rich


#4

John,

I’ve some problem what Rich has mentioned.
If I execute a simple SELECT FROM dual the result seems ok. But Select from a table displays the result from scientific format. Please see the attached screenshot.

The scientific display option is off for me.


#5

I don’t know why it’s not working for you, it works for me. My table has just a plan NUMBER datatype for this column. Is yours the same?


#6

I have a NUMBER(13,10) datatype. I send you some sample data offline.


#7

I can reproduce that. It works fine with NUMBER, but not NUMBER(13,10). I didn’t try anything else yet. I’ll look at this more tomorrow.