Edit command doesn't work, grid is read only

In the editor window, using the edit command it simply acts like "select * from" - populating the data grid with the table contents, but the grid is not editable.

17.1.717.3711 is the first version in which I've seen this problem

Hi Sean,

I just tried this and it works OK for me. Does this happen for every table? Does it also happen if you do a SELECT that includes ROWID? Is your connection read-only?


I haven't tried "every" table, but did try with several tables.

Also tried as different user, including SYS and different databases, none of my connections have the read only flag set.

I can edit in other data grids, like schema browser or F4 describe window.
It's just when I use the edit command.

select with rowid doesn't help. I still can't edit the grid.

Is there a setting somewhere that disables the edit command?
If so, I didn't intend to set it, but maybe I did or somehow it was set as part of upgrading?

Not that I can think of. I'm a bit baffled as to why the select with ROWID doesn't work either if you aren't in read-only mode. When you do an EDIT, we just run a select with rowid behind the scenes.

How about Schema Browser -> Table -> Data tab? Can you edit there?

yes, data tab of schema browser or F4 describe window work

it's only the data grid populated by the edit command that is locked out.

The edit icons are grayed out, the green/red write/read indicator is red. So it's not that the grid is presented as writable and fails, all indicators are that it's supposed to be read only.

Except, obviously, that's not what edit is for.
I've asked another person on my team to test their install.
They are using a prior version (17.0.341.1977) and it worked but will upgrade and try.

I remembered I hadn't deleted my previous install yet, so I fired it up and tried with same user, same db, same table and it worked.

That version was 17.0.353.2906.

Other than resetting the taskbars I didn't make any other changes while upgrading to

Thanks for the update. We're investigating.

This is caused by setting Options -> Oracle -> General -> OCI Array Buffer Size to "Manual". Set it back to Automatic and EDIT will work in the Editor again.

Pavel has fixed it for next beta.


That did it.
Thank you!