Toad World® Forums

Entities get added to all workspaces?


#1

I have several workspaces in my model and every time I create a new entity into one workspace it adds the entity to every workspace and I need to go and delete from all of them. Is there anyway to not do that? It is very time consuming.

I already looked in the help and in the movies but could not find an answer.

Thanks!


#2

Hi,

Right-click the WS | WS Format | General tab and clear checkbox Auto Complete.

Auto Complete - If this option is selected, every object you will create in your model will be automatically added to all Workspaces where this option is enabled.

Tip on how to set up the Auto Complete option for new models:
Select Settings | Options | Physical Model | General tab where you can:

a] select the Auto Complete checkbox
Result: All Workspaces in all new models you will create will have this option enabled. See the WS format of the Workspaces.

b] clear the Auto Complete checkbox
Result: In a new model that you will create, only WS1 will have this option enabled. Why - WS1 is meant as Main Model, other WSs work like submodels. If you add an entity to WS2,3…, it will be automatically added to WS1 (Main model).

I already looked in the help and in the movies but could not find an answer.
It is mentioned in the docs, however in topic Formatting objects. You were probably searching at Entity topic. I will add a reference there too in next release of Docs. CR # 47 002. Thanks for your notification.

Regards,

Vladka


#3

Quick update:
Feel free to watch a new flash movie on this issue:
http://modeling.inside.quest.com/entry.jspa?externalID=1670&categoryID=158

Regards,

Vladka