Error when creating a synonym

I've gotten errors like this for other objects and it gives a line and column number. How do I find what table doesn't exist? I know it's probably the crap code I inherited, but just wanted to ask how to figure this out. Thank you.

Hi Louie,

I don't have a lot of context from this screen shot (it's really zoomed in).

This info comes from Oracle, so we just show you want they give us. You could try re-compiling and see if the error changes.

I guess this is a view because there is a "data" tab. You could get the SQL for the view and try running it in the editor...

Thank you. Having done this stuff for 52 years, you'd think I'd be able to figure it out.

It is a synonym for a view. I have run the script in the Editor and gotten the same results. There are a couple of other ones that give the same error message. I will go through all the tables and views in the script and see if there's a problem. Thank you for your response. I'll try not to be a pest.

52 years! Wow.

You might try going to the Views tab in the Schema Browser and then right-click -> Compile -> All Invalid views in this schema. If I remember correctly, that'll compile them in dependency order, so it should get as many of the valid as possible.


Yes, I've done that before. I still get the error that doesn't tell me where to look. Thanx