How do I prevent my SQL from being modified when copying from an editor that is connected to a different DBMS?

If I copy my code from an editor that is connected to Teradata and paste it into an editor that is connected to SQL Server, Toad modifies my script.

For example it inserted brackets to change select current_date to select [current_date]. It also inserted .dbo as a qualifier for all my tables in the from statement.

This is VERY frustrating when I don’t know what has been modified and is hard to troubleshoot.

Is there a setting I can change to turn off this feature or is it a bug?


It is performing a transform and trying to help. There isn’t any option for this. But you can fool it by saving the Select to a *.sql file, set your other connection to have focus and then open that *.sql into a new editor. *.sql files are not associated to a particular connection

thanks. I wish we could disable this feature. I think I’ll just make sure to copy into notepad before pasting into a different dbms connection.