Toad World® Forums

LDAP Descriptor not populating with Oracle 12c 64bit client


I’m running Toad Professional version (64bit) with Oracle client (64 bit) and when I click on the drop down for the LDAP descriptor connection it doesn’t populate the list.

I can still connect to the databases that would normally appear in the drop down box.

sqlnet.ora contents:


ldap.ora contents:

DIRECTORY_SERVERS= (myoidserver.domain:3060:3061)

UPDATE: The other puzzling thing is that my Oracle SQL Developer from the 12c oracle home (I believe the sql developer is 64bit) is ok to load the ldap entries.
i.e. on sql developer: New Connection > Connection Type > Ldap > Choose LDAP server > Load. <<This works and loads all our databases from the OID server.

Appreciate any assistance anyone may be able to offer


With Toad not running, open Toad.ini and add the following entry under [SETTINGS]:


(you can use whatever path and file name that you want)

Then save and close Toad.ini. Launch Toad and click the LDAP dropdown in the login window. Then check the LDAP.log file for details. Post here if needed.

Hi John,

Thanks for your reply. My logfile generated:

Names.directory_path: (LDAP)

Host: myoidserver.domain

Port: 3060



HomeList.Active.OCIFolder: C:\oracle\product\12.1.0\client_2\bin\


Library Not Loaded:



That means the ldap dll’s weren’t found in the C:\oracle\product\12.1.0\client_2\bin\ folder.

For Oracle 12, it’s looking for this file: ORALDAPCLNT12.DLL

Definitely there…

My PATH environment variable contains the OH bin directory:

C:\oracle\product\12.1.0\client_2\bin;C:\oracle\product\12.1.0\client_1\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\Windows Kits\8.0\Windows Performance Toolkit\

Any other suggestions?

Hmmm. Well, this line:


…the fact that it’s blank in your log file makes me suspect that something isn’t right in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE. An uninstall/reinstall of your Oracle client may resolve it. If you have another Oracle client already installed, you can switch to it on your login dialog. That may also resolve it.

Finally, if you just type in the connection name in the LDAP dropdown, even though the list is empty, you may be able to connect anyway.

Hi John,

There were references to a previously installed Oracle client (client_1) in my registry under HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE. I’ve removed these entries (the oracle client had previously been uninstalled) however the issue still remains.

Is there anywhere else in the registry that may contain references that may be picked up by TOAD?

Everything in the registry seems to point to the correct location (the current client - client_2)

I can confirm that I can connect when I type the connection name in the LDAP dropdown.

I’m hoping to get this sorted, as I’m the first in our business unit to upgrade to the new Oracle client as we’re beginning the process of upgrading our databases to 12c. This will become more of an issue for us once more developers start to upgrade their Oracle clients and they can’t query the LDAP descriptor drop down.

Is there a way we can force TOAD to pickup a value OraCall.OracleHomePath? Can we set a specific environment variable? Is there a TOAD config file that we can modify?



If you export HKLM\SOFTWARE\ORACLE and email the .reg file to me, I’ll give it a try here.

You can send to

Hi, I had the same problem with TOAD 12.7, but all I did was to make sure my $ORACLE_BASE\bin was the first one in the PATH environment variable. I had ODAC installed which was first in the variable, but i swapped them around and that worked. What I find bizarre is that ODAC does not even have the ORALDAPCLNT12.DLL file present. I searched throughout my directory and i only have ONE and only ONE – ORALDAPCLNT12.DLL. So, not sure why TOAD cannot find it, whether $ORACLE_BASE\bin was first or third…

Those ODAC clients have caused problems for us in the past.