Toad World® Forums

Local Storage Connection Connection Issues

As of today, I can no longer see my Local Storage Tables and Snapshots in either TDP 3.4 or 3.5 versions, yet I can still see them on the Beta version 3.6. I have at least 50-70 Local Storage Snapshots that I work with (and refresh), some with hundreds of thousands of records. On 3.4 and 3.5, I can still connect to local storage, but it does not find my Database name, nor the Tables and Snapshots I have created. In addition, I get the error message: Local Storage Database Error - " Incorrect information in file:’.\mysql\proc.frm’ ". Again, in version 3.6 however, the Database, Tables and Snapshots all appear correctly and I can access the data. What can I do to restore Local Storage visibility of my Tables and Snapshots on versions 3.4 and 3.5? Thanks!

I am having the same exact issue. Here is the response I was provided:

www.toadworld.com/…/22557.aspx

I did not try this option.

By installing TDP 3.6 you upgraded local storage and it’s now incompatible with TDP 3.5

You can restore the old version of the local storage by follow these steps

  1.   Move the “C:\Users\{UserName}\AppData\Local\Quest Software\Toad Data Point Hub Data” to “C:\Users\{UserName}\AppData\Local\Quest Software\Toad Data Point Hub Data New” another location.
    
  2.   Start TDP 3.5.
    
  3.   Shut down TDP 3.5.
    
  4.   Copy everything in the “C:\Users\{UserName}\AppData\Local\Quest Software\Toad Data Point Hub Data New\data” directory except the directories hub_information_schema, mysql, performance_schema and any directory that starts with an “_” character back to the new “C:\Users\{UserName}\AppData\Local\Quest Software\Toad Data Point Hub Data\data” directory.
    
  5.   Launch TDP 3.5 and verify that your data is there.
    

Don’t run TDP 3.6 again until you are ready to move permanently. Also if this should not work for some reason just move the “C:\Users{UserName}\AppData\Local\Quest Software\Toad Data Point Hub Data New“ back to its original location.

Sorry for inconveniences

Aleksey

I experienced this on a machine where TDP 3.6b was not installed. Then I installed TDP 3.6b to alleviate the issue.

Aleksey,

I followed your instructions exactly, but after copying the files back and launching TDP 3.5, I now get the following Local Storage Database Error message: Unknown storage engine ‘InnoDB’. Any suggestions? Thanks for your help!

Hi Richard

I am sorry but it looks like the proposed solution does not work and you should copy back the directory.

You can try another way to solve the issue. It’s not very convenient but you should be able to use your data in TDP 3.5

Run TDP 3.6 and connect to local storage and then (while the TDP 3.6 is still running) launch TDP 3.5. In this case TDP 3.5 should use the new local storage engine.

Aleksey

I tried Aleksey’s second suggestion it worked like a charm.

Yes, this worked for me. Thank you for being very responsive and helpful. It was much appreciated!!! Richard

So, TDP 3.6b expired today. What is the workaround for this?

… I did a reinstall of TDP 3.6b and it worked fine.