Toad World® Forums

Location of windows with dual monitor

I am running the latest Toad ( and this has been a persistent problem ever since I got dual monitors. I am running Toad on my right hand or secondary monitor in a window. It comes up fine. The connection dialog is set to automatically come up and it comes up centered in the workspace on my second screen again just fine. I choose a connection and the schema browser and sql worksheet pop up in windows (as I have them set to automatically come up on connection) again just fine in the workspace. I then go to Database->Diagnose and choose any option from there (for sure the Tablespace Map and the Log Switch Frequency Map) and they come up WAY to the left of my workspace and I have to scroll the Toad workspace bar way to the left to find it. Why doesn’t it come up centered in my active Toad workspace? What setting do I need to tinker with perhaps to convince it to open centered on my current workspace?

Yeah, that shouldn’t happen. I just tried to reproduce this but it worked OK for me.

Go to Toad Options -> WIndows. There you can configure Toad to remember (or not) the size and/or position of each window. I have it set to remember everything. I tried making Toad very wide to span both monitors, then open a window and move it to the 2nd monitor. After that I resized Toad so it only was in one monitor and reopened that window. Since the window would have been off screen, Toad put it in the center. I tested using the tablespace map.

Can you look at these settings and give me some steps to reproduce it? If you aren’t sure, please zip up your user files folder and email it to me at



Thanks for the reply! I will be glad to zip up my user files but if selecting the Save Size and Save Pos on all the windows will solve it then I will be satisfied.

You don’t know of a quick way to select all of the checks in a column do you? :slight_smile:

Right-click on the column header and you can check/uncheck all/selected. That trick should work on any grid you see in Toad with a checkbox column.

Very cool! Didn’t think about the right click.

Yes. Marking them all to save it worked fine. Don’t know why it had defaulted to such an odd position to begin with but I have carried my settings from several versions (at least from 9) so they could be kind of ugly.

THanks for the solution!