Toad World® Forums

Nissing IE Notation


#1

I reversed engineered a schema (TDM model attached). I don’t see the expected tics and crows feet. Can anyone determine what is wrong?

Thanks,
Dave Reed

SI_Units.txp (2.07 MB)


#2

Make sure you are using IE notation.

[cid:image001.png@01CBB3CB.7EBFE7B0]


#3

Should have mentioned that. IE notation is set per the model attached to the original message.


#4

Aaaagh. I just noticed a few minutes ago that there is nothing wrong. I happened to blow the model up to a larger size, you can see the crows feet. When you look at the print (fit to page) or are at 10 to 40% magnification, they can’t be seen. At 50% you just barely make them out.

Vaclav:

The model I attached is an excellent example of the issue I have concerning not being able to enlarge the notation graphics. Please take a look at the model to see my concerns.

Thanks,
Dave Reed


#5

Dave,

may I ask what is the reason why fonts are set to sizes from 32 to 144 in you model? By changing the font sizes to big values you minimize benefits of ZOOM pane (View | Loupe) that can be docked and of course, go into troubles when trying to print the model - because other graphics are too small, as you wrote me.

I recommend you to change font sizes back to 8 or 10 for your entities, enable option “Visible page boundaries” in options to see where your printable area ends and use the Zoom/Loupe pane to see details. This will also allow you to work with Zoom (CTRL+mouse scroll) better.

Regards,

Vaclav


#6

Vaclav:

The problem here is printing and fit to page. Try printing the model to 11x17 paper. With smaller numbers, the text is not large enough on paper.

What is the relationship between “visible page boundaries” and printable area?

There was a later follow-up to my message. The crow’s feet were not missing. They were too small to be seen.

Thanks,
Dave


#7

Hi Dave,

I did some additional tests with your model and found a bug in “fit to page” option. This option doesn’t accept objects on workspace but, incorrectly, takes all the workspace area - which is defined as larger than necessary.

As a workaround and instead of using “fit to page” in Page format dialog, try this:

  1. Use standard font size, e.g. 8.
  2. Disable option Fit to page on Page Format dialog.
  3. In Settings | Options click section Graphics, enable check box Visible Page Boundaries to see where your printable area ends - in TDM you will see black lines that divide the whole workarea to printable sheets.
  4. Rearrange your entities to be printed on one sheet, if possible. Of course, if you create multiple entites it may be hard to put everything on one sheet.

Another workaround:

  1. Use standard font size, e.g. 8
  2. Export diagram to picture and shrink the picture in third party image editor.

I apologize for the bug in Fit to page option, we will look into the matter.

Find attached your model - modified - and output to PDF printer.

Regards,

Vaclav
DocumentTDM.pdf (19.7 KB)


#8

Hi Dave,

I did some additional tests with your model and found a bug in “fit to page” option. This option doesn’t accept objects on workspace but, incorrectly, takes all the workspace area - which is defined as larger than necessary.

As a workaround and instead of using “fit to page” in Page format dialog, try this:

  1. Use standard font size, e.g. 8.
  2. Disable option Fit to page on Page Format dialog.
  3. In Settings | Options click section Graphics, enable check box Visible Page Boundaries to see where your printable area ends - in TDM you will see black lines that divide the whole workarea to printable sheets.
  4. Rearrange your entities to be printed on one sheet, if possible. Of course, if you create multiple entites it may be hard to put everything on one sheet.

Another workaround:

  1. Use standard font size, e.g. 8
  2. Export diagram to picture and shrink the picture in third party image editor.

I apologize for the bug in Fit to page option, we will look into the matter.

Find attached your model - modified - and output to PDF printer.

Regards,

Vaclav
SI_Units2.txp (2.07 MB)


#9

Dave,

additional tests resulted in the following finding: there is no error in Fit to page option. The problem is that in your model there is an empty text object. See enclosed screenshot.

You probably deleted text instead of the object… or added the empty text there by mistake.

When you select all objects in your model by pressing CTRL+A you will find there a strange set of black “adorners”. When you delete this object, change fonts back to 8pt and change layout of your model, printing should be OK.

Regards,

Vaclav


#10

Vaclav:

Thanks, but I have moved on with your suggestion to not use “Fit to Page”. It appears to be working well. I will have a follow up Email sometime this week.

The CTRL+A functionality may be useful to me. Several schemas print two pages with one blank. I can’t find any objects outside page 1. Selecting all the objects may also not work, because I again must search a number of pages, albeit the object will be more obvious. Is there any other way to identify outliers?

Dave


#11

Hi Dave,

I am glad the workaround works for you. If you wish to check your model for empty text graphics, download a simple macro from:
http://modeling.inside.quest.com/entry!default.jspa?categoryID=34&externalID=4426

It will help you to locate empty Text graphics on your workspaces. After you import the macro, click Macros | Search graphics and see output in Message Explorer. You need to run the macro for all your workspaces one by one (or modify the macro to iterate all WS in your model.)

Regards,

Vaclav