Toad World® Forums

Pasting from Vim into the editor

I am running, and I have noticed that when I paste SQL from Vim in Windows 10 that it locks up Toad. I can replicate it every time. Is there a workaround for this? Or do I need to wait for a newer release?

Welcome back.

Probably going to need Dev's input here, but in the meantime... guessing that Vim might be using some special hidden chars that Toad doesn't like :slight_smile: .

Curious: what happens if you copy/paste content from Vim to a simple text file, and then copy/paste from the text file to the Toad Editor? Same thing happen?

Alternatively, is there a provision in Vim to copy as plain text?

Please try the beta, I believe this is fixed. If not, please let me know and I will give you some steps to debug this in the beta.

Get the beta version here. Leave 14.0 installed. The beta will copy 14.0's settings, and then each version will carry their own copy of the settings after that.

Well, now it's working, and I haven't changed anything. I suspect it's something to do with my Windows environment. I've tried this for several days, and it didn't work each time. I had tried copying the text from Vim to Notepad, and then to Toad, and it didn't work, either, which doesn't makes much sense to me. @JohnDorlon, I can't do betas due to cyber policy.