Toad World® Forums

Toad Editor behaviour copy paste ctrl chars

I am using Toad for Oracle v.13.3.0.181 when I use CTRL C or V (or other CTRL commands) in the editor they work but as soon as I type the next letter or hit return the letter from the CTRL command is pasted.

Example: CTRL V will paste whats in my paste buffer + the char "v" when I press space or return or type a letter.

Any ideas anyone?

This has come up in support recently, and they discovered that it only happened for users with Citrix Workspace app 2006.1 installed. Unfortunately, I don't think they have discovered a workaround yet (other than to remove Citrix Workspace).

Thanks John, that would make sense as I have a Citrix update run on Monday :frowning: which is when the problem started. I guess I will have to raise a bug - unless its already noted.

Do you have a non-citrix machine that you can test with? We don't have a citrix environment set up here, and the support guys tried installing that Citrix Workspace app but could not reproduce the problem. Maybe something else needs to be configured? Hopefully some way we can fake it w/o having a full citrix environment?

Unfortunately no I do not.
I am using Toad for oracle version 13..3.0.181 and Citrix workspace 19.12.0.119(1912) - I am not sure which version Citrix was patched from but it was working with the same version of Toad prior to the Citrix patch applied on Monday.

I am still getting big problems so I will raise a bug - It makes Toad extremely difficult to use :frowning:

I’ve been trying to get a Citrix environment set up to reproduce it. It's been slow going because I am working with someone in a very different time zone. Hopefully I'll be able to make some progress today.

Hi John
Sounds good - I have raised an official ticket now SR Number:4751227 so it is being investigated.
br
Ian

Yes, guess who they sent it to. :smiley:

Good to know I have the best guy on the case :wink:

As they say in the stamp collecting world, philately will get you anywhere! :grin:

Cheers,
Norm. [TeamT]

1 Like

Be honest - how many people just looked up "philately"? I did!

Here's what I know so far:

  1. The Citrix Workspace App, when installed with the "App Protection" option, is somehow causing this. If the "App Protection" option is disabled, it does not happen.
  2. It does not happen on Windows Server versions (because the App Protection option is disabled in those versions).
  3. It happens in Toad versions 10.0 and newer. It does NOT happen in 9.7 and older.
  4. It doesn't seem to be related to grids, syntax editors, or any other component in Toad. Keyword: SEEM. It might be related to grids. But definitely not the editor component.

I'll keep digging tomorrow.

1 Like

:smiley: :smiley: :smiley: :smiley:

Cheers,
Norm. [TeamT]

Thanks for the update John.
I am having to move to SQL Developer for now :frowning: the bug is causing me to make to many mistakes.
Hope you can find a work-around/fix soon.

If you are allowed to re-install the Citrix Workspace app, and can do so with the "App Protection" option disabled, Toad will stop doing that.

I will contact the department who install software and ask if they can re-install without app-protection but I guess its switched on for a security reason.
I am in Denmark so they time difference is an issue for us too.
I'll write again when I hear something.

I have now got Citrix Workspace removed and Toad is happy again :slight_smile: ....and so am I.
I look forward to the bug fix in the future but for now thanks for the help John.

br
Ian

1 Like

Great. We have a lot of eyes on this. It's been tough to figure out exactly why this is happening but I believe we are getting close. We'll let you know when it's solved.

We believe that this is actually a bug in Citrix Workspace App, not Toad. ​ The App Protection option of Citrix Workspace app seems to have a keyboard hook and is incorrectly processing the HC_NOREMOVE code. ​

Toad is not the only application to experience problems when Citrix Workspace App is installed with the App Protection Option. For example, in Excel, if I am editing a cell, CTRL+A does nothing. It should select the entire cell contents (and does when Citrix is not installed). Toad's problem is more severe, but this illustrates that Citrix Workspace App is causing problems for other apps.

I have opened a support case with Citrix. I'll update here what they say.

Solution for Toad 14.0 or newer

  • Edit Toad.ini (click here if you need help finding it).
  • Add CitrixWorkspaceAppWorkaround=1 under [SETTINGS]

Solution for Toad 13.3 and older

  • If you don't need Citrix Workspace App, uninstall it.
  • If you need Citrix Workspace App, uninstall it and reinstall with the "App Protection" option unchecked.

Update: Citrix support case is still open, but they have their developers in on it now, so hopefully we'll be getting a Citrix update soon that will fix it.

1 Like

Well, I was researching this issue and came across this thread. @JohnDorlon I have to admit that I knew what 'philately' was. I know because I was a philatelist, and also @NormTeamT probably told me this joke MANY moons ago.