Toad World® Forums

Pivot Grid Opening Problems

I am using version 4.0.0.624 and having issues with the pivot grid. When I run a query and right click in the results I can choose send to pivot grid but nothing happens. My result set is small. Also, when I try and open a tpg file created in a prior version nothing happens–I don’t get an error message. It just doesn’t open. Is there a known bug about this?

Hi David,

I tried it with Editor and with Query Builder result but I don’t have any problem with sending to Pivot Grid. Can you please tell me more information? What database provider are you using? What previous version are you used for generating tpg file?

Thanks

Hi Filip,

I am connected to an Oracle database. The previous version of Toad I used was 3.6.0.3276.

In the new version I also tried to send a table right to a pivot grid with a right click, and got the following error:

In the prior version of Toad I had no problem doing this.

Thanks.

David Woomer

From: Filip Cevela [mailto:bounce-FilipCevela@toadworld.com]
Sent: Tuesday, August 23, 2016 7:38 AM
To: toaddatapoint@toadworld.com
Subject: EXTERNAL RE: [Toad Data Point - Discussion Forum] Pivot Grid Opening Problems

RE: Pivot Grid Opening Problems

Reply by Filip Cevela

Hi David,

I tried it with Editor and with Query Builder result but I don’t have any problem with sending to Pivot Grid. Can you please tell me more information? What database provider are you using? What previous version are you used for generating tpg file?

Thanks

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad Data Point Forum notifications altogether.
Toad Data Point - Discussion Forum

Flag this post as spam/abuse.

Hi David,

I tried with my Oracle 11 and I still don’t see any problem. From your image it looks like there should be some problem with some datatype which are you using. Can you confirm that it happen on more tables with different datatypes in columns (some simple table with few columns would be great). If you have still problem also on other tables then I would like to ask if you can create Support Bundle (in Help -> Support Bundle) and send it to me.

i have another user who has the same issue. I entered QAT-8501 for this but need some help reproducing this.

can you do the following?

  1. Open the Pivot grid in TDP 3.8. RIght click and chose Edit Undrlying SQL. Copy the SQL into an SQL editor.

  2. Keep the SQL editor focused and generate support bundle from the Help menu. Chose ‘No’ when it asks you about row number.

  3. Post or email directly to the complete support bundle (I need several files in there) and the pivot grid file that won’t open in TDP 4.0.

You can email me: debbie.peabody@quest.com

This issue is fixed for patch release TDP 4.0.1. It is also in the current Beta if you would to try.