Toad World® Forums

power outage - now toad won't start.


#1

we had a power outage last night. toad was running at the time. Tried to launch it this morning and it hung on the splash screen. Had to kill it. Tried again and now won’t loads real slow splash screen came up with the “checking for critical files…” message.

What are my options here? Reinstall?

Windows 7 64b
toad 10.5


#2

I would try renaming your application data directory, that would force toad to
rebuild some things from scratch.


#3

i backed up then removed all the files/directories in

C:\Users\psloan\AppData\Roaming\Quest Software\Toad for Oracle

Still loads real slow. I see that it has created a new directory structure in the above directory. Still takes minutes to get to the splash screen.

–pat


#4

Yeah, but do you get any farther? I was under the impression toad quit working,
not that it was slow to startup.


#5

yah it is real slow like several minutes just to get to the splash screen. I am in the process of reinstalling now. Will let you know how that goes.

Thanks.

–pat


#6

ok this is weird. the reinstall did not get any better. But I did not clean out the registry or program files directory. Uninstalled again, deleted the data directories and tried to delete the quest program directory. But I got a file/directory in use error when trying to remove the directory. I only have toad from quest, so I thought this was strange as it all should be unistalled. I made sure nothing was running and rebooted again. Still the directory’s would not delete. I narrowed it down to the following directory and found out that a service was running:

“Manages DB2 registry entries for backward compatibility purposes for the DB2 Copy TACOM26”

This service was using a file in the directory:

C:\Program Files (x86)\Quest Software\Toad for Data Analysts 2.6.1\SQLLIB\BIN

I stopped the service and put it on manual start. I then can delete the directory.

Why would this service be running and using a quest file to run?

Any ideas?

Continuing with the reinstall after removed the quest directory and asociated registry and data directory items…


#7

Toad for Data Analysts installs its own custom DB2 client for IBM DB2 LUW and
z/OS connectivity support.


#8

Ah, i guess i let the default install and it installed the analytics. That service is part of that. I never properly unstalled the rest of the quest software that comes with toad pro.

Still trying to get a clean install and loading time back to normal.

–pat


#9

3rd unstintall, reg purge,directory purge, reinstall worked!

TOAD is back to loading in under 30seconds!