Toad World® Forums

Problems with Toad 14.0 crashing

Oh, it gets hung after you hit Enter (at first I thought you were hitting enter to make the dialog go away). OK, yes, I can reproduce that and I believe that one is fixed in beta.

I can also easily reproduce the issue with these commands (, 64-bit).
But in my case I am not getting any dialog box, where to click OK (P3 - dismiss the dialog)
Having that said, I will press enter and crashes.

So quite a lot of (3 known to me) "toad crashing" issues with this version (, 64-bit) :confused:


@raul.kaubi Are you able to use the beta?

I don't have time at the moment to try beta, but sounds like you are pretty confident it is fixed so I will just wait for the next official update, thanks!

The next official version is due out sometime around March.

Although I highly recommend taking the time to install and use the beta. The majority of the changes in it are bug fixes.

I just installed beta, version.

Couldn't reproduce any of these crashes:

  • In editor word wrap enabled with long oneliner sql
  • In editor selecting text and using spacebar to delete it
  • In editor running sql with invalid table, F9 and then enter


Excellent. Thank you for the feedback.

You may have noticed, there is a Change Log in the comments section below the beta download links.

I just upgraded to 14.0 and have had nothing but issues with Toad hanging. Had to force restarts at least 3 times so far this morning.

Enough is enough! Clearly this version is not fit for purpose so will be reverting back to 13.3. That will teach me for upgrading to a newer version when it is first released.

I think more testing of products before releasing is require to avoid customer disappointment like this.

1 Like

Hi @paul.hill

Sorry 14.0 caused lock ups. I believe those are fixed in the current beta, and they seem to be fixed for @raul.kaubi too.

I hear you about quality. My goal has been to get Toad as solid as possible. I know users are tired of problems, and I want to fix them. We do perform a lot of testing, but it's impossible to predict everything that could cause a problem. I can tell you that I've been primarily focused on bug fixes for the past few versions.

Please try the beta. Toad for Oracle 14.1 Beta. You have to keep 14.0 installed to run the beta, but you can also keep 13.3 installed too. They each keep their own copy of settings, and run completely independent of each other.


Hi John,

Thanks for your email.

I understand Toad is a huge application and there are many pieces of functionality that could potentially cause issues, but on all three occasions this morning I was editing and running SQL in the editor. It really doesn’t get much simpler than this and this should be bread and butter for Toad.

I’m not interested in using a Beta as I don’t have enough spare time to “test” Toad. To be productive I need a tool that just “works”, so I have reverted back to 13.3 and I won’t be planning to upgrade again for some time.



Hi Paul,

Thanks for the feedback. I hope you'll give 14.1 a shot when it officially comes out.


Hi John

Think I've found another bug. Fresh install and new workstation.

Day one, I started editing a long SQL statement with multiple sub selects and unions. On folding the inner sub selects so I could see all of and work on the outer group by's etc. On mouse wheel scroll, toad would die. Have experienced editing test SQL code and package implementation.

Fold code, mouse scroll, toad dies.

Would appreciate to know, if you can reproduce, if this is fixed in beta before I decide on beta or installing older 13.3


I have been experiencing the same issues and found that disabling the "Auto Replace" prevents Toad from crashing in this scenario. Instead when you press enter, it just deletes the invalid table name.

Hi @paul.beck

Can you send me the SQL so I can try it? You can email it to me at

Or let me know if you can replace with something built in to the database (like the source for ALL_TABLES, for example).


Thanks for the tip! That worked for me also :partying_face:

@jim.schmitz and @andshe I tried to reproduce this with 64 bit Toad 14.0 but didn't have any luck. Do you have default values in the auto-replace list or have you added some?

@andshe Would you mind trying it in beta to see if it is fixed there with auto replace enabled? You can get it here.

Leave 14.0 installed if you install the beta. The beta won't run without latest official version also present. The beta will import your 14.0 settings but keep its own copy of settings after that.

I have the 64 bit installed and I was able to reproduce it there (SELECT * from xxxx , presss F9, hit enter, crash). I had the default values in auto-replace. I unchecked and that fixed the issue, but obviously would like to use the auto-replace. Our company manages our PCs, so I have to go thru some hoops to install/update software so I am fine with waiting till 14.1 comes out officially.

I also have the defaults in the auto-replace list. If it helps, here is the about page from my install.
I have the same issue with my PC being managed by my company that Jim has. I won't be able to install the beta.

ok, thanks anyway.

Edit: Ah! Yes, I can reproduce this in 14.0 and it does appear to be fixed in beta. I forgot that I had to run with F9 in the steps. ok, I think we're good on this one for next version. @andshe @jim.schmitz

I had a ticket open back in Dec., and moved to Beta versions. It still would lock up, with the default beta settings and the suggested.
I do want to pass an update as to the locking up I've been experiencing. This past week, on the last Beta,, I have only a couple of times, maybe, with a lock-up, even with the one database I seem to lose connection too far often that I do with other databases. By 'lockup" I mean I have to force close and restart.
What has been my different MO is that I do not keep the various windows, usually schema browsers and editors maximized, or not for very long. I also, but not always, have the 'Transactions' window open.
I hope this offers some insight.
This week I will go back to the current production release and see how that goes.
Long-time user, but no expert, since v. 6.0-ish.