Toad World® Forums

Procedures in a package not displayed in the Procedure box using Set Parameters and Execute

We are migrating from Oracle RDBMS 11.2.0.3 to 12.1.0.2. In preparation for this, we have created the new database and imported the objects from the old database.

A defect was found in TOAD 12.6.0.53 in regards to the procedure editor trace into function. The procedures in a package are not displayed in the Procedure box using “Set Parameters and Execute” when debugging using “Trace Into”. This works fine when connecting to our old database, (11.2.0.3), but not on the new database, (12.1.0.2).

I raised an SR with Dell and they verified that it is a defect - CR117496. The SR technician also stated that he believed that this was addressed in TOAD 12.7. I downloaded 12.7.0.76 Beta and was able to verify that this has not yet been addressed with the build that I installed.

I just wanted to raise this to verify that it will be addressed in a future build.

It’s fixed for 12.7. We’ve had a lot of internal builds lately, which is why it hasn’t made it to beta. Oracle changed the contents of ALL_ARGUMENTS, which is what caused the problem.

Awesome! Thanks for the info, John!

Hello John,

For some time, I’m stuck with TOAD 11.6.1.6 and I can’t upgrade. So:

  1. Is there a patch for 11.6.1.6?

  2. Alternatively, is there any workaround apart upgrading to TOAD 12.7?

Unfortunately, we only rarely do patches (usually when the bug would cause a nuclear holocaust or kill a puppy). In the time it takes to do a patch, we’re usually doing a new release. In fact, we just released 12.10 so even asking about 12.7 is pretty outdated.

Also, there’s really no workaround. This was caused by a change in Oracle that we didn’t know about. Once we knew, we fixed it and the fix was released in 12.7. This is also a case where Toad worked for the DBs that were in production at the time. As Oracle makes changes, we follow but we can’t make all of the older versions of Toad compatible with the newer versions of Oracle.