Scheduled tasks won't run in 15.1 after copying user settings

I installed TOAD 15.1 on a new machine. From a different machine, I exported my TOAD 15.0 settings and then imported them into TOAD 15.1 on the new machine. Using TOAD 15.1 on the new machine, I scheduled Automation Designer apps using Task Scheduler. When the Windows Task Scheduler program tries to kick off those tasks/apps, the apps fail on some of the steps. I get an error in the Execution Log that says "Password not specified. Command line execution requires a saved password on the login screen, an overridden connection using the -c command line option, or a parameter file. Refer to the help for more information." Running the app manually from Automation Designer works fine. I reviewed the TOAD help documentation but didn't find anything useful. What am I doing wrong here?

It sounds like the passwords did not get imported into your new Toad install.

You can import them like this:

  1. Go to login window on old Toad
  2. Click the "Export" button on login window's toolbar.
  3. Check "included encrypted passwords" and specify a master password.
  4. copy the export file to the new PC
  5. import the export file using the "Import" button on new Toad's login window.
  6. check the "include encrypted passwords" box and specify the master password.

Hi John,

I was able to run all of the automation steps manually from Automation Designer, so I don't believe passwords to the connections was an issue. I did try your solution and followed your steps to export passwords from TOAD 15.0 and then import them into TOAD 15.1, but it did not solve the issue with Task Scheduler. Clicking 'Run from here' in Automation Designer has no issues and the app runs smoothly. Running from Task Scheduler leads to failure.

That message definitely is about not having the password.

I have 2 thoughts.

  1. Look on the login window, in the lower left hand corner, and make sure "Save passwords" is checked. If it's not, then check it, and then log in as the connection in question to get its password re-saved.

If that's not it....

  1. I'm wondering if maybe the connection got out of sync somehow when you transferred everything. In automation desginer, right-click the scheduled app and choose "Change connections" Select the connection if it's not already selected, and then OK

Save passwords is checked, so good there. I did open each step and verify the correct connection. That seems to fix the issue for one particular automation. I was then able to successfully run the automation from Task Scheduler. Unfortunately, I have 50+ automations, many of which have >10 steps, and >1 connection. It will be painful to fix that for each automation one by one. Any idea if there's a less manual solution?

If you right-click to change connection on the app on the left vs the action (the step) on the right, the new connection will be applied to all of the steps.

Also, you can multi-select apps on the left to change connections for multiple apps at once.

The only thing I can't offer a better suggestion for is the ones with multiple connections.

This really should "just work" so the connections are found automatically after importing from another PC. I'll look at that for next release.

Ok, thanks for the suggestions. I also tried to import Automation Designer app files (.txt) on their own and schedule them separately, but that didn't seem to help either - still had issue with Task Scheduler. If I figure anything out, I'll follow-up here.

Just updating in case anyone runs into similar issues. My team manually updated/verified the connections for each action in each automation designer app. It took a day's worth of clicking, but seems to have solved the issue and the scheduled tasks are running fine now.

We'll have this fixed for version 16.1.

For anyone else who has this problem: It only happens when the Oracle client path on your old PC is different from the Oracle client path on the new PC. So make the path the same on your new PC and it should work. @thirstypretzels I'm sorry I didn't discover that sooner to potentially save you a day's worth of clicking.