Toad World® Forums

Automation designer asks for credentials to schedule a schema export

Hi, I have Oracle database 18c XE and Toad for Oracle 13.3.0.181.
I used Automation designer to schedule a task to export schema. In a specific wizard step, it asks for OS user credentials. The user I am using has no password. Can I pass this step? Or do I have to assign a password for the user? Is there a way to tell toad that the user has no password? I tried clicking "ok" without writing a password but it did not accept that. P.S. there is no other users in the system.

I'm not sure, but I think you could schedule it from Windows instead of Toad. Make your scheduled action call Toad with parameters like this:

-c username@dbname -a "ActionName"

I can't see the name of your action in your screen shot (Something like "Generate Schema Script 1" unless you renamed it). Specify that instead of "Action Name".

Set up the login window to remember your passwords.

I noticed it creates a windows task to call Toad with the following parameters (-a "Sample Code Quality App->Generate Schema Script1"). So, it depends on windows. But it's weird that I am choosing the radio button that enables the action to run only when user is logged on, however, it asks for a password!

It may be a windows scheduler requirement.

It's not. I tried creating a basic task through Windows task scheduler to run calc.exe and it did not ask for a password.

Oh, ok, great. So just schedule your action via windows instead of Toad and you're all set.

Or, set up a password for your OS account and if you don't want to type the password, just set it to autologin

1 Like

Using Windows task scheduler worked. Where can I find the autologin option in windows? I think you're using linux?

I am definitely not using Linux.

You can configure Windows to auto-logon with a few registry tweaks. This says "Windows Server" but it works on any version of Windows.

1 Like

Any way, I will consider using windows directly as a solution. But does asking for credentials when I am using the account I am already logged in to run the task considered a bug in Toad for Oracle? Is there a way to report it? Thanks a lot.

Yes, I'd call it a bug if it's not required.

Please try using the latest version, and if the problem still exists, we'll fix it for the next version. We don't do patches for prior versions.

You can get the latest version here.

1 Like

Logon is already automated in my case because(I think) my user is the only user on the system and it does not have a password. I think it has to do with Toad's privileges or something.