Toad World® Forums

Schema browser data grid allows multi-select for some tables, but not for others


#1

When I’m viewing some tables in the Schema Browser I am able to select multiple cells or rows very easily in the data grid by dragging the mouse, or shift key + arrows. For other tables, I can only select a single cell and that’s it. For the tables where I can do multi-select, it shows a hollow triangle looking icon in the leftmost grey column. For the tables where I can only select a single cell, it shows a solid black triangle. I want to be able to do multi-select in these tables too.

Is there an option that needs to be set/unset? Why does single select seem to only happen for some tables and not others?


#2

The only way I can get the solid triangle is when I first select a table and haven’t clicked inside the data grid yet. As soon as I click inside the data grid, I get the hollow triangle - which represents the focused row.

I think that a solid triangle represents the current row (where the cursor is) in the grid, but the row is not selected. Once the row is selected, and focused, you get the hollow triangle. Also, you can have a row that is selected but not focused, represented with a dot icon.

Anyway, I think the key here is if you rt-click and check/uncheck “row select”. If you have the “Save layouts” option checked in options -> Schema Browser -> Data tab, this setting gets remembered per-table, along with column order and widths.


#3

I have the same issue since upgrading to 13.1.0.78. I didn’t had any problems selecting content in the data grid before.
I know there’s a “Row Select” option, but that doesn’t make any difference.

The strange part is, if I describe a table and select the “Data” tab at the new “Describe Objects” window, I’m able to select multiple cells both by dragging the mouse around or by selecting complete rows.


#4

Maybe something got out of whack in your saved grid settings. Does right-click -> Reset Columns help?


#5

No it doesn’t. :frowning_face:
CTRL-A doesn’t work either.


#6

MDI or SDI mode? If you don’t know what I mean, it’s probably MDI.


#7

I think it’s MDI. But the windows are in full screen. (Both the Application window and the child windows).


#8

You can be sure by checking Options -> General. Application Style on the RHS. We’ve had a few things not work right due to the introduction of this option.

Hm, but I guess it would be consistent with every table if this were the cause.

So, it works with some tables and not others, or just sometimes it works and sometimes it doesn’t, or what? Can you give me some steps to reproduce it?


#9

It is MDI.

Well, I don’t know what’s causing it, but at the moment I can select cells in the data tab for one table but not for another. And this is currently reproducible.
And a restart of the application doesn’t make any difference.


#10

can you send me the “create table” statement for a table that it doesn’t work on?

send it to me in a private message if you don’t want to post it.


#11

Sure. Here’s one very simple table:

CREATE TABLE flat_imports
(
   id_flat_import     VARCHAR2(24 CHAR) NOT NULL,
   description        VARCHAR2(100 CHAR) NOT NULL,
   further_infos      VARCHAR2(4000 CHAR),
   record_created     DATE DEFAULT SYSDATE NOT NULL,
   record_modified    DATE DEFAULT SYSDATE NOT NULL,
   is_predefined      VARCHAR2(1 CHAR) DEFAULT 'N' NOT NULL
);

I omit the constraints.


#12

still no luck reproducing it here. I filled it with random data. I wouldn’t think that this is data related but you could test that by making another table just like it, then rt-click -> Data -> Generate. Just take the defaults in the window that appears and click the green “run” triangle at the top.


#13

I have, as suggested by you, created a new table and generated test data. (With the default settings).
Selecting multiple cells does not work with this table either.

Although I have to correct my statement. At first it didn’t work. I then selected other existing tables until I found one where marking worked.
After that, the marking worked for the newly created table as well.

Right now, this is the behavior:

There are three kinds of tables:

  • A: Marking always works
  • B: Marking never works
  • C: Marking works if table of kind A was previously selected and does not work if table of kind B was previously selected.

The newly created table is of type C.


#14

It seems like maybe you have some settings that have gone awry.

Let’s try this:

Main Menu -> Utilities -> Copy User Settings.
Check “Reset to a clean set of user files”
OK.

That will rename your settings folder and then Toad will restart, looking freshly installed. If you want to get some settings back (like connections), I can help you with that afterwards.

assuming version 13.1, the folder will get renamed like this:
C:\Users(your user name)\AppData\Roaming\Quest Software\Toad for Oracle\13.1 to
C:\Users(your user name)\AppData\Roaming\Quest Software\Toad for Oracle\13.1_bak


#15

Hello,

I have, as suggested, called the function “Reset to a clean set of user files”. After the restart I tried the table where I knew that marking never worked. The result is that I can currently mark cells as desired on all tables.

As far as restoring the settings is concerned, I’d definitely like to restore the connections, because that’s over 500 of them. And also the settings for the code formatter.


#16
  1. Shut down Toad
  2. For Connections, copy User Files\Connections.XML from the _bak to the new folder.
  3. For formatter, copy User\Files\FmtPlus.opt from the _bak to the new folder.

#17

Okay, that worked. Thanks.

I’m sure there are still a few settings that aren’t right, but I’ll find them.


#18

You can probably copy over Toad.ini to get a lot of options back. I think the offending settings were in User Files\Databases(DB Name)(Schema Name)\ *.TNI


#19

I’ll try that. Are the settings for Editor / Font and Styling included?


#20

EditorLexers.xml contains the editor styling options.