Schema Browser - Export Data

It appears that when you have exported data from a table previously and then there are changes to the table (additional columns) and the export is going to clipboard as INSERTS it system uses the previously exported table structure and not the current table structure. Please note, once you change the type of export and then back it seems to be fine. Also, this was the only table I had exported previously and again this time.

Hi Andy,

I just tried to reproduce this and it worked fine for me. Here are the steps that I followed. If yours were different, please let me know the details:

  1. Go to Schema Browser. Pick a table and go to "Data" tab on the right.
  2. Right-click in the data grid and choose "Export Dataset"
  3. Exported to clipboard with the "insert statement" format.
  4. Double-click the table in the schema browser and added a column with a default value.
  5. Schema Browser updates to show the new column (this won't happen if Options -> Schema Browser -> Left Hand Side -> "Refresh Schema Browser after an object is altered" is unchecked.
  6. If option referenced in step 5 is unchecked, you should refresh schema browser at this point.
  7. Right-click in the data grid. Same settings as before should all be present. Click OK.
  8. New column is in the export.