Toad World® Forums

Since installing TOAD for Oracle 11.0.0.116 large package, slow response

I went through some suggestions posted on line about checking the preferences (specifically, making sure that the Hightlight table names is UNCHECKED), but at times while in a large package I see the line/character change about one a second, waiting for the editor to catch up to what I have typed. Is there a comprehensive, up to date checklist of what to do if this occurs? I have also run Barracuda malware agains the computer (nothing found) and no other programs seem to be experiencing this degradation of performance.

Debra Miller wrote:

“I went through some suggestions posted on line about checking the preferences (specifically, making sure that the Hightlight table names is UNCHECKED), but at times while in a large package I see the line/character change about one a second, waiting for the editor to catch up to what I have typed. Is there a comprehensive, up to date checklist of what to do if this occurs? I have also run Barracuda malware agains the computer (nothing found) and no other programs seem to be experiencing this degradation of performance”

I cannot provide a checklist, but I had the same problem. What helped me was un-checking “Enable Code Insight pick list” under the Editor | Code Assist section in the options.

John

MedSolutions has been recognized for providing “An Outstanding Customer Service Experience” under the esteemed J.D. Power and Associates Certified Call Center Program. www.medsolutions.com

Important Warning: This information is intended for the use of the person or entity to which it is addressed and may contain information that is privileged and confidential, the disclosure of which is governed by applicable law. If the reader of this message is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this information is STRICTLY PROHIBITED. If you have received this message by error, please notify MedSolutions sender at the address shown immediately and delete the related message from your files.

Unfortunately there are some performance hits with very large PL/SQL. The syntax highlighter is complex and has many rules that must be evaluated. I’ve worked with the edit memo developer to see if there’s anything that can be done and the suggestion was to eliminate as many rules from the syntax highlighter as we can, in particular those that perform dynamic highlighting like showing matching parenthesis. This is not an option for us to do with the shipped highlighter, but you can clone the PL/SQL highlighter (see View|Options|Editor|Behavior) and edit it to remove as much from there as you can live with and see if it helps. Similarly you can try changing to the plain text highlighter via the right-click|Language/Syntax Highlighting menu and see what that does for you. It won’t highlight, but if you are just in a large package for a short time it should allow you to work faster.

Michael

[Attachment(s) from Michael Staszewski included below]

I don’t know if it will make any difference, but I tried to clean up some of the rules in the syntax highlighter. If you’d like to try it then do the following…

  1. Locate your appdata folder. It’s location can be found in Options by checking out the General page and making a note of the application data directory setting.
  2. Close Toad.
  3. Navigate to the appdata_path\User Files folder and rename LexLib.lxl (or make a backup of it)
  4. Copy the attached LexLib.new as LexLib.lxl in the User Files folder.
  5. Start Toad.

If you like what you see you can safely run this in Toad 11 even though I tweaked it in the Toad 11.1 beta or you can roll back to your old LexLib.lxl file if you wish.

Michael