Toad World® Forums

SQL Recall export override Ctrl+S shortcut

Pressing Ctrl+S shortcut on an unmodified file in Editor Toad opens SQL Recall Export window. It seems SQL Recall catch the shortcut if the panel is active and the Save as command is disabled currently.

Good Afternoon urban.tomas.

If you click View->Toad Options, then scroll down to Toolbars->Shortcuts, you will see a list of commands and shortcut keys to activate them. I only ever use the defaults.

Click on Shortcuts at the headings end of the list, once or twice to bring those commands with shortcuts assigned to the top. Now scroll down the list until you see where CTRL+S has been assigned. Mine shows up against the command "Save File" in the "File" category - so I don't have your problem.

You may see another command with CTRL+S assigned and this might be where the problem arises. The "SQL Recall" shortcut is the F8 key.

To reset one or both, select the offending command and click the Reset current button. Repeat as necessary. That should fix it.

Cheers,
Norm. [TeamT]

SQL Recall window Save as command directly assigned with Ctrl+S shortcut. If recall window is active and gets focus it steels the Ctrl+S keystroke .

I've no other command assigned with Ctrl+S shortcut under Options|Toolbars|Shortcuts.