Toad World® Forums

TASK SCHEDULER


#1

After I test the automation task and runs successfully; I clicked on Automation button to put the TAS file in schedule but a sub_screen called Progress gets open and it stays there forever. How can I fix the problem. Until last week I did not have any problem but when the Beta version 2.0 expired, then I got an error, so I uninstalled the beta version and I am using now only version 1.1. I even deleted the tas file created with the Beta 2.0 and I created a new tas file but nothing seems to help with the problem. Also I tried fixing the problem by un-installing and installing version 1.1 with the CD but I still have the same problem.


#2

When you see the progress window is there a “Details” button. This button will provide any details of errors it has encountered. We have run into one issue recently. If there are any jobs scheduled by any users other than your logged on user, our job scheduler has an issue starting up. To check this, go to the windows job scheduler (Start menu|accessories|tools) and delete any jobs that you are not an owner of. Also, if you have changed your password recently you should check the passwords on any existing tasks.

See attached screenshot. I was not able to use the TDA schedular when I had the circled jobs. After deleting them I was fine.

Also, if you don’t want to delete them you can manually use the windows scedualar or upgrade to latest Beta as this issue has been solved.

Debbie
OthersJobs.png


#3

All the jobs I have under scheduling tool are mine. I am the only who uses the computer so I am the creator all of the task scheduled to run. After the tas file is created, I run a test; once the test is completed, I clicked on Schedule button; at this point the small window gets opened and it has on the top, Completed 0 of 1 server; the indicator runs all the way and stays there forever. The performance on my spped is decreased that in order to cancel the job, I need to click several time end task. Anyway, in this sub-window there are only 2 options OK and cancel; I do not see any detail option to select. As a temporal fix, I am going directly to the scheduling tool and I am adding the nex task manually; but I hope a solution to this problem can be found because it was very convenience to create the schedule file from Toad. Thanks for any help you might provide on this matter


#4

I’d like to find out more info on the issue. When you have time can you open up the Job Management window from the Tools|Administrator menu and let the progress window display for as long as possible? I want to see if the window ever times out or opens successfully without the scheduling of an automation task.


#5

I am not sure if I understood your question so in case you noticed I did not, please take the following as extra notes on the problem:
I have other tasks thar are scheduled to run and those tasks are still running at the scheduled time without any problem.
The Schedule tasks window does not show the new task that I want it to put in scheduled from Toad because the file is never created. Toad remains in a frozen status so the only thing I know is thay the Job management is not responding.
I leave yesterday Toad running for the entire day and never see any different result; the schedule file was never created so there is not status to check on the scheduling screen.
The window task manager has 2 toad icons: one has the toad picture and the other one is just a blue square; both files have the name Toad for Data Analysis- [job management] Not responding. Under Processes, Toad.exe uses 133,016k.
Unfortunatelly I cannot take a screen shot of all these events because I cannot even open a word document.


#6

In my earlier request I was asking to open up the Job Management window without sending it an automation script to schedule. I would like to determine what step the Job Management window is having trouble with.

Job Management goes through three steps.

  1. Selects what servers to register jobs. (It can read from remote servers)
  2. Reads and loads the existing jobs from those servers.
  3. Displays job scheduling window for you to enter details.

The attached screenshot shows the steps. Can you verify the following:

  1. Is your pc selected on the left side of the window?
  2. Does the progress window ever go away?
  3. If you send a script from Automation do yo ever get the scheduling attributes window?

I am unceratan if step 2 is actually complete and the window in step 3 is getting stuck behind somewhere.

It sounds like I will need to make a bug report to the team that handles Job Managerment. In addition to the answer of questions above can you send a support bundle and screenshot of your windows scheduled jobs and screenshot showing the issue to my email adderess? We can take this off line for further discussion. dpeabody@quest.com
automationSequence.png


#7

1: My pc is selected on the left side of the window.
2: The progress window never goes away.
3: I do not get the scheduling attributes window when I send a script from Automation because the process stays on step 2.