TNS Database drop down is not populated when creating new Login

I am trying to create a new login and the TNS Database dropdown is not populated. This worked before, but it has been a while (and a couple of version updates) since I had to create a new login.

The drop-down on the previous connection screen for database is properly populated.

The Jun2017 topic did not work as I rebooted Toad and nothing changed.

Anyone have any ideas on how to resolve this issue.

Are you saying that the TNS dropdown is not populated at all when the login window opens?

where is your tnsnames.ora file?

Only for "create new login" window "single". I just tried with "multiple" and I was able to create a login.

Session -> New Connection -> Add Login Record (Add Single).

Since I have it working with the "Add Login Record (Add Mulitple)', I am okay.

ok, so it's loading on the login window, just not the "add single"?

It's loading there for me. Where is your tnsnames.ora file? (In a folder specified by TNS_ADMIN environment variable? In your Oracle client's network/admin folder? somewhere else?)

Also, for what it's worth, you really don't have to use "add login record" at all. You can just specify new values here and then click "Connect". A login record will be created automatically if it doesn't exist yet.

The first thing I tried was your specify new values suggestion and that didn't work for me.

Nonetheless, I am good now. Thanks for your response.

Hi Andrew,

If that didn't work for you, then maybe there are two bugs here.

Can you please clarify what you meant by "that didn't work for me". Were you not able to connect? Were you able to connect but a login record didn't get created? something else?

Also, I'm glad you got past the problem, but if you can help me figure out how it happened, then I can fix it. I'd really like to understand your TNS config so I can try to reproduce this. I tried a few things here and it consistently worked for me.

I am assuming that you are on version 17.1. Please let me know if that is incorrect.


I'm on 17.0.341.1977. I have made the request last week to be updated to 17.1 and am still waiting for our support team to do it.

I tried the specify new values again, and it worked. I suppose I fat-fingered the password.

Here is an image of my original issue.

Session -> New Connection -> Add Login Record (Add Single).

From the connection screen, the Database dropdown is populated

Hi Andrew,

Thanks for the details.

I am guessing that you do not have a TNS_ADMIN environment variable, but rather have your tnsnames.ora file in your Oracle client's network\admin folder. It's fine if you want to leave tnsnames.ora in that location, but if you also specify TNS_ADMIN and point it to that location, the problem will be fixed (after restarting Toad).

This will be fixed for Toad version 2024 R2, which is the version after 17.1. The version numbering system is going to change.


Thanks John,

You are correct, I do not have a TNS_ADMIN environment variable. points to tnsnames.ora file? I will try that. I will have to make a request through our support staff as they have our development machines ridiculously locked down.

Actually it points to the folder which contains tnsnames.ora. Not the file itself. You can also put sqlnet.ora and ldap.ora in that folder, if you use those files.

I like to point it to a folder outside of my Oracle client. This way, when I change from one client to another, I don't have to mess with tnsnames.ora. Also I have multiple Oracle clients and this allows them all to use the same tnsnames.ora.

FYI: If you add/change this environment variable, Toad won't notice it until Windows is restarted.

Here is mine:

I got the TNS_ADMIN environment variable installed. The dropdown now populates.

thanks for you help.

Hi Andrew,

You're welcome. Thanks again for the details so we can get this fixed for next version. Please let me know if you find any other problems.