Toad World® Forums

TNSNAMES not refreshing in New Session dialog

MorningAll,

  • Toad 12.1.0.22 64 bit
  • Oracle 11.2.0.4 64 bit
  • Windows 2008 and 2012 in the cloud. 64 bit.
    My tnsnames.ora is in the usual place, oracle_home\network\admin. It consist of an IFILE command to pull in our central tnsnames.ora from a network share. I have the drive mapped as a specific drive as Oracle doesn’t work with \servermname\share type paths.

IFILE=“Y:\TNSNAMES_CENTRE\tnsnames.ora”

My own stuff goes here.

It seems that when I update the IFILE’d file, Toad doesn’t notice that this has happened and doesn’t refresh the list in the drop down. If I update my local file, it does, and the new entries appear.

I think we need a button to manually force a refresh of the tnsnames.ora, locally, so that we can pull in changes made in our IFILE’d files too.

I can change my local file from the tnsnames editor button on the New Session dialogue, which is fine, but it would be nice to be able to refresh the drop down from the dialogue itself.

Also, with my IFILE as listed above, running a syntax check in the tnsnames editor results in an error saying that the referenced file cannot be found.

Morning Norm,

Did you try closing and re-opening the login window to cause a refresh? I know it refreshes when you do that, but I’m not sure I ever tried this technique with an updated remote IFILE, just an updated local file.

-John

Hi John,

you don’t hear from me in ages, then suddenly, I’m like a stalker! [:O]

Yes, I did try closing the windows and opening it again, but to no avail. The changes in the IFILE were not picked up.

I changed a hostname in a TCP connection in the IFILE’d file and until I edited a space into the local file, it simply refused to believe that I’d changed anything. I tried everything, short of rebooting Toad - which was due to me having far too many windows and connections open.

Quite alright, Norm!

I just took a glance at the code - starting with version 12.7, and F5 on the database list in the login window will cause a refresh. 12.6 and prior, yeah, I guess you’d have to restart Toad.

BUT - if you know what database you want to connect to, you can just type it into the dropdown - it doesn’t actually have to be in the list as long as the Oracle client can find it.

-John

Hi John,

yes, I knew about typing it into the dropdown - I always do that. But Thanks.

The problem was that the host name in the IFILE had changed, the existing one was no longer contactable.

When I tried to connect, Toad still attempted to go to the old server, and timed out on the connection.

I’ll just have to cope with this, it doesn’t happen too often, I hope, and I can just use the tnsnames.ora editor to fiddle the local file to get it to read in the IFILE.

As ever, thanks very much.