Toad World® Forums

Toad 3.2: Frequent lock ups after trying to cancell a query!

Often, if I have a long running query that I try and stop by using the red ‘X’ cancel, query, it does stop the query on the host, but 99% of the time, it also locks Toad. No keys or mouse clicks are recognized and I have to use the task manager to kill the Toad program.

I am clueless as to how to avoid this!

Running Toad 3.2 on Win7 32 bit, against Vertica, using the 4.1 ODBC Drivers.

We have done many fixes or Vertica in TDP 3.3. Can you down load the Beta and use the Verica 6.0 driver and see if this works better for you?

Debbie

I can try the 3.3. beta, but can not use the Vertica 6.0 ODBC driver as it is not compatible with the Version of the Vertica database we are using. (Vertica Analytic Database v5.0.14-0)

I will let you know how 3.3 works

Tried 3.3 for two weeks, no different.

I am having the same type of issues with Toad Data Point 3.6.1.3294 -

I am accessing Vertica Analytic Database v7.0.1-0 with

Vertica ODBC Driver 6.01.03.00 on my PC.

I can still access parts of toad, like open up help, but have an hourglass when my cursor is over most of it, with no response.

Also, when I kill Toad with Windows Task Manager, it first pops up a window asking if I want to save files (unsaved queries) but the buttons on that popup are unresponsive, even if I cancel the killing of the process in Task Manager.

To SueLynn:

Thank you for posting in Toad World!

I was unable to reproduce your issue. You may review my steps below:

My Reproduction Attempt

  1. Launch Toad Data Point 3.6.1.3294
  2. Connect to HP Vertica (I have a 6.01.02.00 ODBC Driver connecting to a 6.1.2 Database)
  3. Execute a ton of queries in one go.
  4. Push the "Stop" button. After a few seconds, a popup appears.

I would recommend reproducing the issue and sending us a support bundle. It can be generated using Help -> Support Bundle, then sending/attaching the zip file to us.

If you can do it while the client is mostly unresponsive, that would give us the best data. If you are unable to, then generating the bundle after the client has restarted will still be sufficient.

How to generate a support bundle

  1. Launch Toad Data Point through the shortcut with the parameter /log=all.

  2. Reproduce the issue and ensure the error message appears (If applicable).

  3. Select Help -> Support Bundle
    2577.2.png

  4. A new tab will appear. After it's done generating the bundle, Right-click the tab -> Save File to save the .zip file to any directory of your choosing.
    0044.5.png

  5. Return to the Toad World thread and Post a Reply using Rich Formatting
    5step.png

  6. Compose a message

  7. Select the Options tab next to Compose, then click Click to Add to add the .zip support bundle
    7step.png

  8. Post when you're ready!

We apologize for the inconvenience,

Software Developer I,

  • Joshua Liong

I haven’t been able to reproduce it yet, now that I’ve turned on the logs.

But it happened multiple times in the past.

I don’t remember the exact query I was using or sequence of actions,

I don’t know if the query itself actually has started when I run into the issue - there is an hourglass but I don’t see any query listed in the ‘Background Process’ window so I can’t stop it. But if I run into the problem again in my regular course of work I will gather the information and post it. Will it cause problems if I just leave the logging on as default?

Thanks!

To Suelynn:

There are two considerations with logging. Logging may impact client performance as Toad will be writing to the toad.log file more often. Another note of concern would be that the size of the Toad.log file will continuously grow.

Generally, having /log=all as default should not cause any problems.

Let us know if we can be of further assistance!

Software Developer I,

-Joshua Liong

It just happened. While the hourglass was spinning, I was able to save my editor file but it did not show it was saved in the tab title. It let me create a support bundle while the hourglass was spinning, and when it finally completed the hourglass was no longer spinning and I could run the query I had been trying. I had misspelled a value in a field in my where clause and so it returned no records, but it became responsive. It is almost like it is waiting for something (like maybe a hidden popup window) that gets cancelled when it creates the support bundle.

I don’t feel comfortable posting the logs on a public board. Should I create a ticket?

To SueLynn:

I forgot to mention that support logs can be sent to the dev team by email. Feel free to attach the support bundle to Joshua.Liong@quest.com. If you can also include the time that the incident occurred in the email, it will help us scrutinize that time segment.

Once I take a look, I will reply to the thread.

Software Developer I,

-Joshua Liong

To SueLynn:

Thank you for sending in the Support Bundle. I regret our team’s findings were inconclusive by looking at the logs. However, your suggestion of a “Hidden Popup Window” is an avenue I would like to investigate.

I have encountered issues with invisible pop-ups in the past. There are subtle clues that indicate the presence of invisible popups, like shadow borders in the middle of the screen. This may be causing Toad to be unresponsive.

If possible, please attach or send in a full screenshot (include the bottom Windows taskbar) when the issue occurs again. I would appreciate the chance to investigate this further.

We apologize for any inconvenience,

Software Developer I,

-Joshua Liong

It happened again today. I was clicking on the little green arrow icon in the top toolbar of the editor window to run a script. At least that was my intention. It did not execute as the results from the previous script were still in the results pane. I thought maybe if I tried to create a support bundle it would clear up as it did last time. But it was taking a really long time to create a support bundle, so I tried to cancel. Did not cancel. But I could open up a help window. I tried to open a different connection but it wouldn't take and when I tried to cancel it wouldn't accept that click either. Help (?) worked. I clicked on some icon that looked like DOS and it was DB2 and it gave me an error message and I could not click out of that.

I could not close the information window and the rest of Toad was greyed out. I have a screenshot of that.

To SueLynn:

I greatly appreciate the level of detail given. The symptoms appear to be straightforward:

Upon execution of a SQL script, the tab becomes unresponsive for much longer than it should be, and executing any other Toad operations cripples the client.

Regrettably, I am still unable to reproduce this issue after modeling my Toad to be as close to yours’ (Using the toad support bundle) as possible.

At this point, I would like to see if this issue occurs on Toad Data Point 3.7.0.974 Beta. This beta should be available until October 20th, 2014.

www.toadworld.com/…/default.aspx

Let us know if you encounter this issue in our latest TDP 3.7.

Software Developer I,

-Joshua Liong

The issue maybe with the database itself. Please go to the ODBC Manager and turn on ODBC tracing. Then start up TDP and produce the hang. When you have the hang capture the odbc File and attach to this post.

I haven’t been using Toad in a while, but I did today and it froze up again and I thought I’d provide the scenario so it would give more info on what might have caused my initial problem. I created a query in the Editor. It started off attempting to auto-provide table names/file names but then stopped and I couldn’t get any autocomplete working after that. I noticed the hourglass when the mouse was over Toad, but it still let me run the query.

Unfortunately, I had a typo in the query and it came back with ERROR 2624: Column “ais” does not exist in the alert window. However, the Toad window got lightly grayed out and when I clicked on ‘OK’ Or the ‘x’ in the upper right hand corner, the alert window would not close. It is frozen, as I can’t do anything. It does bring focus back to the alert window when I click the button, but it does not close. I had not run any queries in this session before the hourglass showed up. It doesn’t seem like any queries are going on - maybe it is trying to get table information for an autocomplete?

The big problem here is that the alert window will not close. I can’t get any logs with this as I can’t click on anything. So something is going on in the background unrelated to any actual queries, that is blocking the ability to close the alert window. (and keeping everything else in a grayed state).

I had updated to Toad Data Point 3.7 and still am using Vertica 7.

It is using between 4-7% cpu and around 100k memory.

Can you download and try our TDP 3.8 Beta. We made some low level changes that might have fixed this.

www.toadworld.com/…/default.aspx