Toad World® Forums

Toad Error Cannot create file


#1

Hello Experts,

Please help me to resolve this issue
I keep getting pop-ups every 5-10 minutes saying

“Toad error Cannot create file “C:\Tmp\TOA9117.tmp”. The process cannot access the file because it is being used by another process”

  • I am running only single instance of TOAD
  • I tried restarting few times TOAD but no success.
  • I have 120 GB free space on my C drive.

Thanks in advance.


#2

It would help us diagnose your problem if you:

  1. tell us Toad version
  2. give us the call stack from the error dialog (click where it says “click here” in the error dialog, then in the next dialog, check the “copy to clipboard” checkbox, then click OK. Then paste your clipboard contents into your message)

You may be able to solve the problem by closing Toad, then deleting the files in c:\Tmp\ that match the TOA####.tmp pattern. But if you can give us the info from step 2 above, we may be able to make changes to prevent this problem from happening in the first place.

Thanks.


#3

Thanks John for prompt response.

  1. Toad version 12.8.0.49
  2. The only option in the pop-up is Jump and Clipboard
    There are actually no files by TOA### in the TMP folder in fact I have tried to change the temp folder to a new location (View->Toad Options) but still getting these annoying pop-ups.
    When I change the folder to a new one it has no files still getting these pop-ups seems TOAD is failing to write anything on this folder or any folder.