Toad World® Forums

TOAD for Oracle 11.6 install


#1

Just installed the 32-bit TOAD for Oracle (along with the 32-bit Oracle instant client 10.2.0.4.0 (oci.dll version included, though, is 10.2.0.1…is that correct?)) on my Windows 7 laptop but it hangs when I start it up.

I have added C:\Oracle Client\instantclient_10_2 to my PATH environment variable as well as NLS_LANG and TNS_ADMIN variables.

I added debug=1 to my toad.ini file and see this:

20:27:05:069 Initializing application
20:27:05:069 Creating GlobalDataModule
20:27:05:132 Performing Toad’s startup tasks
20:27:09:350 Creating main window
20:27:09:365 Create Bitmaps Form
20:27:09:568 Restoring dock layout
20:27:09:677 Checking for Spotlight
20:27:09:693 Checking for SQL Impact
20:27:09:693 Initializing Team Coding
20:27:09:740 Building quick scripts menu
20:27:09:740 Building external tools menu
20:27:10:426 Enabling features based on license
20:27:10:442 Restoring size and position
20:27:10:442 Ribbit!
20:27:11:041 Performing Toad’s command line tasks
20:27:11:041 Application.Run

And it ends at that point.

Should I next see something called Create Log In Form?

Thanks for any help!

Jim


#2

Not sure if this helps or not but I just noticed this in Windows Event Viewer:

__Event filter with query "SELECT * FROM InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA “Win32_Processor” AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace “//./root/CIMV2” because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.

Thanks again for any help!

Jim


#3

Well, on closer inspection, it doesn’t look like the previous Event Viewer message is related…sigh…that looks like a separate issue…

Back to square 1…

Should I see the “Create Log In Form” as the next toadDebug.txt entry? Or something related to the oci.dll file?

Thanks.

Jim


#4

Is this an upgrade or new install?

On Feb 8, 2014, at 10:57 AM, “jimclake” bounce-jimclake@toadworld.com wrote:

RE: TOAD for Oracle 11.6 install

Reply by jimclake
Well, on closer inspection, it doesn’t look like the previous Event Viewer message is related…sigh…that looks like a separate issue…

Back to square 1…

Should I see the “Create Log In Form” as the next toadDebug.txt entry? Or something related to the oci.dll file?

Thanks.

Jim

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#5

Brand new install…thanks.


#6

Double checking now to make sure I am running the 32-bit version of TOAD - downloaded

and ran TOADORACLE_FREEWARE_116_X86.MSI.

Any easy way to verify that it’s 32-bit?


#7

Just checked Task Manager and see this on the Processes tab:

Toad.exe *32

So I am running 32-bit Toad.


#8

Have also found this in Action Center of Control Panel:

Description

A problem caused this program to stop interacting with Windows.

Faulting Application Path: C:\Program Files\Quest Software\Toad for Oracle 11.6 Freeware\Toad.exe

Problem signature

Problem Event Name: AppHangB1

Application Name: Toad.exe

Application Version: 11.6.0.43

Application Timestamp: 50490b08

Hang Signature: 14d7

Hang Type: 0

OS Version: 6.1.7601.2.1.0.256.48

Locale ID: 1033

Additional Hang Signature 1: 14d7b99cfb3b8ca5e1df10a39086a60b

Additional Hang Signature 2: ad45

Additional Hang Signature 3: ad45a677d7fc8e1fef90b50742619ce9

Additional Hang Signature 4: 14d7

Additional Hang Signature 5: 14d7b99cfb3b8ca5e1df10a39086a60b

Additional Hang Signature 6: ad45

Additional Hang Signature 7: ad45a677d7fc8e1fef90b50742619ce9

Not much help, I admit…but anybody have any ideas?

Thanks again.

Jim


#9

I can show what comes in log (on proper install) where you stopped:

16:22:12 Performing Toad’s command line tasks

16:22:12 Application.Run

16:22:13 Create Login Form

16:22:50 Calling OCI connect

16:22:53 Connected

16:22:53 Initializing connection

16:22:53 Getting Oracle version

16:22:53 Fetch session SID

16:22:53 Checking for access to DBMS_TRANSACTION

16:22:53 Checking for SELECT_CATALOG_ROLE

16:22:53 Checking for SELECT ANY DICTIONARY

16:22:53 Checking for SELECT ANY TABLE

16:22:53 Checking access to DBA views

16:22:54 Setting modul e info

16:22:54 Creating Debugger Object

16:22:54 Restricting product features based on Toad security

16:22:55 Checking for RAC support…

16:22:55 Out of RAC support check.

16:22:55 Fetching owner names

16:23:05 TFormToadEditor.Create

So far what I can say seems that Oracle client is not OK (this why LoginForm seems to be not shown.

I’d liek to advise to install Oracle Client 10.2.0.x (administrator option), reedit values of TNS_ADMIN, Oracle_HOEM and SQL_PATH and see if it would start


#10

And another things, trust but verify …

Please let us see results of

dir %USERPROFILE%\AppData\Roaming\Quest Software\

dir %USERPROFILE%\AppData\Roaming\Quest Software\Toad for Oracle\

THX


#11

Thanks, damir.vadas_531, I was wondering if I should be using the “full blown” client as opposed to the instant client - I’ll give that a try.

Here are screenshots from the 2 folders…I hope they insert here correctly:


#12

@ jimclake

Those two folders are two too deep. Please read once more mine paths.

And do not sent pictures but pure cmd output-it is much easier to analyze and to upload.

Brg

Damir


#13

In searching the Microsoft tech support site I found quite a few people who had apps that would not launch or freeze due to a similar problem (same error codes) and the problem was with adobe Flash Player add-ons. The fix was to disable those flash add-ons and in some cases to remove flash player. While this may not be your issue, it would not take long to try to see if it is related.

In addition, here’s an app that seems built to help debug such hangs:

www.nirsoft.net/…/what_is_hang.html


#14

Bert, nice tool. THX for sharing


#15

Problem solved - thanks for helping! It led me to discover a couple of major things:

  1. I could use the latest version of TOAD even though I had to use version 10.2 of the Oracle client - I had made the mistaken assumption I had to use an older version of TOAD.

  2. Also, despite my efforts to install the 32-but version of TOAD into the “Program Files” directory, the installer forced it into the "Program Files (x86) folder. I simply cut the “Quest Software” folder from “Program Files (x86)” and pasted it into “Program Files” and voila! I am now up and running on TOAD 12.1 with the Oracle 10.2 client.

Quite an education I won’t soon forget!

Thanks again!

Jim


#16

Keep in mind this as well:

support.microsoft.com/…/555568