Toad World® Forums

TOAD for Oralce 12.6 has bug?


#1

Hi,

After install TOAD for Oracle 12.6, warning popup window comes out.

English translated message is “Procedure entry point upigpb was not found from OCI.dll dynamic link library.” (Orininal message is Japanese).

Click OK button on popup window, it looks TOAD is working fine.

Launch TOAD -> select DB connection -> Warning popup message here -> Click OK button on popup messgae -> Establish DB connection

This popup message is not appeared until ver 12.5.

How to fix this issue?

TOAD for Oracle Base Edition - English

Windows 7 pro 64bit Japanese

Best regards,

Sato
TOAD_for_Oralce_warning_popup_image.jpeg


#2

Which Oracle client are you using? A newer one may solve the problem.


#3

I’m using Oracle 11g client and databases are all 10g.


#4

I use the 11.2.0.1 client on a regular basis without any problems. If yours is 11.1 then upgrade it.


#5

I am using 11.2.0.3 client.


#6

I get almost the same error, only for another missing procedure:

English translated message is “Procedure entry point OCIDefineByPos2 was not found from OCI.dll dynamic link library.” (Orininal message is Dutch).

I am using a 12.1.0.1 Oracle client


#7

Sorry, I don’t see these procedure names in our source and I don’t see these errors. I am not doubting you, but I don’t know what else to suggest. You might want to open a support case for it.


#8

Thanks, I have opened support SR.


#9

The issue has been resolved.

My PC has several Oracle client version, and ennvironment “path” has several entries to different Oracle client home bin directory. In the “path” value, first entry points to 32bit 10g Oracle client home bin directory, so I moved 64bit Oracle client 11.2.0.3 bin directory information to become first, then this warning popup window won’t come out.

before: C:\oracle\product\10.2.0\client_1\bin;C:\oracle\product\11.2.0\client_1\bin;…

after: C:\oracle\product\11.2.0\client_1\bin;C:\oracle\product\10.2.0\client_1\bin;…


#10

Oh, and that would explain why I never saw the message. When I install Oracle clients on my computer, I always install them in order from the oldest to the newest. Thanks for the follow up and I am glad that Support was able to help you fix this.