Toad World® Forums

Toad for SQL Server Trial can no longer connect to SQL Server

I installed the Freeware version of Toad for SQL Server, then got a 30 day Trial license. There are 28 days left on the Trial license.

Both worked fine for a few days. Then Toad for SQL Server Trial stopped being able to connect to my database, while Freeware can still connect.

The error returned by the Trial version is:

SQL Server Database Error: The multi-part identifier “dbr.is_local” could not be bound. Invalid column name ‘role’. Invalid column name ‘role’. Invalid column name ‘role’. The multi-part identifier “dbr.is_local” could not be bound. Invalid column name ‘synchronization_state’. Invalid column name ‘synchronization_state’. Invalid column name ‘synchronization_state’. Invalid column name ‘synchronization_state’. Invalid column name ‘synchronization_state’. (Remembered answer: “OK”. Enable)

Any ideas how to fix this problem?

Hi ,

This error sames to send by SQL Server . Could you tell me how you get this error?

Could you try to connection with another login , Do you know if there is anything changed on your server or your permission?

Cathy.

I get this error trying to connect to one instance of SQL Server only. I can connect to another instance on a different machine and also to SQLEXPRESS.

The problem occurs only with the Trial version. The Freeware version connects to the database.

The only change was that I went home and came back to work the next morning. This is a database on my development machine used by nobody but me.

The error from SQL server indicates to me that the Trial product is trying to access something called dbr.is_local. I have no idea what that is.


Update: I created a SQL server login and can connect using SSA instead of Windows authentication. After doing that, then I can connect using SSA.

Update: I can login using SSA, but not if an initial database is set in the Toad connection manager.

Update: Now I can login using SSA, but only with an initial database set in the Toad connection manager.

  • Eric