Toad for sql server

New in this forum and new TOAD for SQL user.
I have scheduled a TOAD task that ran with no problem but, since 1 week I cannot run this task because of this message "invalid object name" for one of my views in my SQL statement.
See the full message below.
What is interesting is that I can run SQL on this table (I choose the view in Object explorer/Generate SQL/SELECT Statement).
Thank you for helping.

14/06/2023 08:20:53: Executing export using connection hq-bi-lsnr-ods (CORP\xxx, M3_ODS_PROD is not XQuery Connection
14/06/2023 08:20:53: Export_1 - Invalid object name 'M3_ODS_PROD.M3JDTP300.V_OSBSTD - TF: Sales statistic (UC)'.
14/06/2023 08:20:53: Invalid object name 'M3_ODS_PROD.M3JDTP300.V_OSBSTD - TF: Sales statistic (UC)'.
14/06/2023 08:20:53: Failed

Are you accessing the table, or the view referencing the table?

Have you tried re-defining your view with a simpler name? It appears you've got some special chars in the view name (namely the colon or parens) that could be tripping up SQL Server or Toad.

Hello Gary
my full SQL statement has 3 select with union all.
If I run separately the 1st and 3rd that are selecting [M3_ODS_PROD].[M3JDTP300].[V_OOHEAD - TF: CO header file (OA)] and [M3_ODS_PROD].[M3JDTP300].[V_MITAFO - MF: Forecasting (MF)] there is no issue while I've one only with [M3_ODS_PROD].[M3JDTP300].[V_OSBSTD - TF: Sales statistic (UC)].