Toad World® Forums

TOAD Installation error

Windows Vista Basic.

When I install Toad in my laptop it sends me the following error and does not allow me
to go I closed the tool Toad

C:\Program Files\Quest Software\Toad For Oracle\user\Files\Lexlib.lxl
was not found and is
needed please contact Quest Support…

I saw a reference to this error some days ago in the forums? You can search for
it. Had something to do with running as administrator solves the problem?

Groetjes,
Wim

On Thu, Apr 7, 2011 at 02:37, ypranathi wrote:

Windows Vista Basic.

When I install Toad in my laptop it sends me the following error and does
not allow me
to go I closed the tool Toad

C:\Program Files\Quest Software\Toad For Oracle\user\Files\Lexlib.lxl
was not found and is
needed please contact Quest Support...

Morning all,

Windows Vista Basic.
Oh dear! :frowning:

When I install Toad in my laptop it sends me the following
error and does not allow me to go I closed the tool Toad

C:\Program Files\Quest Software\Toad For Oracle\user\Files\Lexlib.lxl
was not found and is needed please contact Quest Support…

I had this very problem on Windows 2008 R2 just last week. It is
documented here (for now!):

http://asktoad.com/DWiki/doku.php/faq/answers/installation?s=lexlib#why_
does_toad_not_run_on_windows_vista_unless_run_as_administrator

However, the problem is this:

  • Vista no longer allows user files to be created below the “program
    files” directory tree.

  • You are installing an old version of Toad - say 9.6.

  • Older versions of Toad attempt to put files into the “program files”
    tree when running and especially at initial startup.

You have a couple of solutions:

  1. Turn off Vista’s extremely irritating User Account Control “utility”.
    It is this that is stopping you from working.

  2. Right click the Toad icon, and run as administrator. You must supply
    an admin username and password of course.

  3. Follow the instructions at the above location on copying the required
    files from where Vista has put them (c:\document\applications data or
    similar) back to the user files folder beneath where you installed Toad.
    I found problems with this on Win 2008R2 as there didn’t appear to be
    any redirected files!

The file lexlib.lxl is required as is lexlib.old - which is, I think,
created when Toad first runs correctly.

The problem is all down to the fact that Bill Gates aka Microsoft
decided, off his own back, to prevent millions of user from running
their applications in the way that they always did. There was absolutely
no need for it - all it did was “break” lots of applications AND give
Vista an even worse reputation that it already had. :frowning:

(Other opinions are available of course!)

Good luck.

Cheers,
Norm. [TeamT]

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk

Please check your directory,

C:\Program Files (x86)\Quest Software\Toad for Oracle\

there are folder name “User Files” please make copy this folder as “User” in the same parent directory, and it will work